summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsukanka2023-01-27 01:33:24 +0800
committersukanka2023-01-27 01:33:24 +0800
commitb468b267fdf03886dd78098af2a7d266edb918cb (patch)
tree8bdf49d73a493147a145466927d747d9b7a6be7a
downloadaur-b468b267fdf03886dd78098af2a7d266edb918cb.tar.gz
add package
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41a27c23a838
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = r-acceptancesampling
+ pkgdesc = Creation and Evaluation of Acceptance Sampling Plans
+ pkgver = 1.0.8
+ pkgrel = 1
+ url = https://cran.r-project.org/package=AcceptanceSampling
+ arch = any
+ license = GPL
+ depends = r
+ source = https://cran.r-project.org/src/contrib/AcceptanceSampling_1.0-8.tar.gz
+ sha256sums = 5784fa82f3287ef5d57ed294334e61974f77a261fc8c1e90f4c76d8c367841c9
+
+pkgname = r-acceptancesampling
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3287c1f18c04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: sukanka <su975853527@gmail.com>
+
+_pkgname=AcceptanceSampling
+_pkgver=1.0-8
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//[:-]/.}
+pkgrel=1
+pkgdesc='Creation and Evaluation of Acceptance Sampling Plans'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('5784fa82f3287ef5d57ed294334e61974f77a261fc8c1e90f4c76d8c367841c9')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: