summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-11-18 13:05:21 +0200
committerPekka Ristola2023-11-18 13:05:21 +0200
commitc47f19e98bc55ca0c014aadadedaca19609c916a (patch)
tree2dd7e71747d48344b616df9a64d881ee429249ad
downloadaur-c47f19e98bc55ca0c014aadadedaca19609c916a.tar.gz
Version 1.0.0
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD51
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be7a38c230da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = r-alabaster.files
+ pkgdesc = Wrappers to Save Common File Formats
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/alabaster.files
+ arch = any
+ license = MIT
+ checkdepends = r-testthat
+ checkdepends = r-variantannotation
+ depends = r-alabaster.base
+ depends = r-biocgenerics
+ depends = r-biostrings
+ depends = r-rsamtools
+ depends = r-rtracklayer
+ depends = r-s4vectors
+ optdepends = r-biocstyle
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ optdepends = r-variantannotation
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/alabaster.files_1.0.0.tar.gz
+ md5sums = ea12d81dadbad7340c5f2d6be276a697
+ sha256sums = 52c451b6c1a5f827a791ee99f3367596569f39a117f4cd368536247b52c98a80
+
+pkgname = r-alabaster.files
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee8f23ff575a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=alabaster.files
+_pkgver=1.0.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Wrappers to Save Common File Formats"
+arch=(any)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(MIT)
+depends=(
+ r-alabaster.base
+ r-biocgenerics
+ r-biostrings
+ r-rsamtools
+ r-rtracklayer
+ r-s4vectors
+)
+checkdepends=(
+ r-testthat
+ r-variantannotation
+)
+optdepends=(
+ r-biocstyle
+ r-knitr
+ r-rmarkdown
+ r-testthat
+ r-variantannotation
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('ea12d81dadbad7340c5f2d6be276a697')
+sha256sums=('52c451b6c1a5f827a791ee99f3367596569f39a117f4cd368536247b52c98a80')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+}