summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-10-15 08:34:36 +0300
committerPekka Ristola2023-10-15 08:34:36 +0300
commit8a7bd13a02a37e7495415c42702001cdc10e817c (patch)
tree4d02554573d7fe16d60da1242257a221c618f1ea
downloadaur-8a7bd13a02a37e7495415c42702001cdc10e817c.tar.gz
Version 1.0.0
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD49
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05dfb2508990
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = r-alabaster.ranges
+ pkgdesc = Load and Save Ranges-related Artifacts from File
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/alabaster.ranges
+ arch = any
+ license = MIT
+ checkdepends = r-testthat
+ depends = r-alabaster.base
+ depends = r-biocgenerics
+ depends = r-genomeinfodb
+ depends = r-genomicranges
+ depends = r-iranges
+ depends = r-s4vectors
+ optdepends = r-biocstyle
+ optdepends = r-jsonlite
+ optdepends = r-knitr
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/alabaster.ranges_1.0.0.tar.gz
+ md5sums = 846f2604ddc36ae98f28443f4b12d305
+ sha256sums = af879e64215719d6b2afb823dce503181fc149feb190716ffdb4efd32ac6692d
+
+pkgname = r-alabaster.ranges
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cdf8afd55cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=alabaster.ranges
+_pkgver=1.0.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Load and Save Ranges-related Artifacts from File"
+arch=(any)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(MIT)
+depends=(
+ r-alabaster.base
+ r-biocgenerics
+ r-genomeinfodb
+ r-genomicranges
+ r-iranges
+ r-s4vectors
+)
+checkdepends=(
+ r-testthat
+)
+optdepends=(
+ r-biocstyle
+ r-jsonlite
+ r-knitr
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('846f2604ddc36ae98f28443f4b12d305')
+sha256sums=('af879e64215719d6b2afb823dce503181fc149feb190716ffdb4efd32ac6692d')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+}