summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 01:36:53 +0800
committerSukanka2022-06-06 01:36:53 +0800
commit85d858f3d48957552ded63154e68d20e70ad5505 (patch)
tree4fbeed5c08e151912111f940e05143c25d25d491
downloadaur-85d858f3d48957552ded63154e68d20e70ad5505.tar.gz
add r-annotationtools
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec0831b1ffd8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-annotationtools
+ pkgdesc = Annotate microarrays and perform cross-species gene expression analyses using flat file databases
+ pkgver = 1.70.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/annotationTools
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-biobase
+ optdepends = r-biocstyle
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/annotationTools_1.70.0.tar.gz
+ sha256sums = a1b0f9ac64c402f0de44b9c5a79f1deccaf1b4010dd989379043b5f889204b88
+
+pkgname = r-annotationtools
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50e6d3ac3666
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=annotationTools
+_pkgver=1.70.0
+pkgname=r-${_pkgname,,}
+pkgver=1.70.0
+pkgrel=1
+pkgdesc='Annotate microarrays and perform cross-species gene expression analyses using flat file databases'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-biobase
+)
+optdepends=(
+ r-biocstyle
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('a1b0f9ac64c402f0de44b9c5a79f1deccaf1b4010dd989379043b5f889204b88')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: