summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 01:40:43 +0800
committerSukanka2022-06-06 01:40:43 +0800
commit68607b3591552b6a898b90a06f6d8442af53e0a9 (patch)
treec8547cbc664391cb5db10887882e695e71e49cd5
downloadaur-r-anylib.tar.gz
add r-anylib
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..057edbe25811
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = r-anylib
+ pkgdesc = Install and Load Any Package from CRAN, Bioconductor or Github
+ pkgver = 1.0.5
+ pkgrel = 3
+ url = https://cran.r-project.org/package=anyLib
+ arch = any
+ license = CCPL:by-nc-sa
+ depends = r
+ depends = r-biocmanager
+ depends = r-curl
+ depends = r-devtools
+ depends = r-httr
+ depends = r-withr
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://cran.r-project.org/src/contrib/anyLib_1.0.5.tar.gz
+ sha256sums = 759b53ecc58136458220108a72004f360404ad2769cbf6ead48dcf09212a3df5
+
+pkgname = r-anylib
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c7efa825e32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=anyLib
+_pkgver=1.0.5
+pkgname=r-${_pkgname,,}
+pkgver=1.0.5
+pkgrel=3
+pkgdesc='Install and Load Any Package from CRAN, Bioconductor or Github'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('CCPL:by-nc-sa')
+depends=(
+ r
+ r-biocmanager
+ r-curl
+ r-devtools
+ r-httr
+ r-withr
+)
+optdepends=(
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('759b53ecc58136458220108a72004f360404ad2769cbf6ead48dcf09212a3df5')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: