summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2023-03-26 18:55:17 +0300
committerChristoph Fink2023-03-26 18:55:17 +0300
commit5fb6ba6f3293d76081d214bfded02f472c7ebb9c (patch)
treed91538b50af40e21591054b2b6c57d5a96fd603e
parent0462d965a3db913dfd1d292a27b20b9fef87da68 (diff)
downloadaur-5fb6ba6f3293d76081d214bfded02f472c7ebb9c.tar.gz
upgpkg: r-anytime 0.3.9-2
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD35
2 files changed, 26 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0ca016c0f28..37d0e23aafaa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,11 @@
pkgbase = r-anytime
pkgdesc = Anything to ‘POSIXct’ or ‘Date’ Converter
pkgver = 0.3.9
- pkgrel = 1
+ pkgrel = 2
url = https://cran.r-project.org/package=anytime
arch = i686
arch = x86_64
license = MIT
- checkdepends = r-gettz
- checkdepends = texlive-core
- checkdepends = r-tinytest
depends = r>=3.2.0
depends = r-bh
depends = r-rcpp>=0.12.9
diff --git a/PKGBUILD b/PKGBUILD
index 9cb4bec71315..ceaf24908da4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="Anything to ‘POSIXct’ or ‘Date’ Converter"
url="https://cran.r-project.org/package=${_cranname}"
license=("MIT")
pkgver=${_cranver//[:-]/.}
-pkgrel=1
+pkgrel=2
arch=("i686" "x86_64")
depends=(
@@ -18,11 +18,26 @@ depends=(
optdepends=(
"r-gettz"
)
-checkdepends=(
- "${optdepends[@]}"
- "texlive-core"
- "r-tinytest"
-)
+
+# The unittests for `r-anytime` have multiple circular
+# dependency chains.
+
+# As such, the tests can not be run on first build.
+# While R packages from CRAN, generally, are well-tested
+# before they are released, in some situations, you want to
+# have thorough testing on your own end.
+
+# To run the tests, first build this package without `check()`
+# (i.e., as-is) to bootstrap `r-anytime`. Then, on subsequent builds,
+# (assumining you have a local repository that is accessible from
+# the build chroot), uncomment the lines defining `checkdepends`, below,
+# as well as the `check()` function further down
+
+# checkdepends=(
+# "${optdepends[@]}"
+# "texlive-core"
+# "r-tinytest"
+# )
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
b2sums=("867cca7faadc29cb99e4ae8428eabd0e3fa00e1c1f0553d3a0d8275c5526743a11dff340b1cacac3ae03bc294f2c9968110234d55e99a6ebc43c7bf413c0b58f")
@@ -32,14 +47,14 @@ build() {
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
-check() {
- R_LIBS="build/" R CMD check --no-manual --as-cran "${_cranname}"
-}
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual "${_cranname}"
+# }
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
cp -a --no-preserve=ownership "${srcdir}/build/${_cranname}" "${pkgdir}/usr/lib/R/library"
-
if [[ -f "${_cranname}/LICENSE" ]]; then
install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
fi