summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 01:41:55 +0800
committerSukanka2022-06-06 01:41:55 +0800
commit86cebaf01370b255900dcf3cb44293e2d9aaca99 (patch)
tree4279233c7a212674bb8bf6b2168cdf4f0cd4a07a
downloadaur-86cebaf01370b255900dcf3cb44293e2d9aaca99.tar.gz
add r-apalyzer
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD52
2 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e626b646693
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = r-apalyzer
+ pkgdesc = A toolkit for APA analysis using RNA-seq data
+ pkgver = 1.10.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/APAlyzer
+ arch = any
+ license = LGPL
+ depends = r
+ depends = r-deseq2
+ depends = r-dplyr
+ depends = r-ensembldb
+ depends = r-genomicalignments
+ depends = r-genomicfeatures
+ depends = r-genomicranges
+ depends = r-ggplot2
+ depends = r-ggrepel
+ depends = r-repmis
+ depends = r-rsamtools
+ depends = r-rsubread
+ depends = r-rtracklayer
+ depends = r-summarizedexperiment
+ depends = r-tidyr
+ depends = r-variantannotation
+ depends = r-hybridmtest
+ optdepends = r-annotationdbi
+ optdepends = r-biocstyle
+ optdepends = r-knitr
+ optdepends = r-org.mm.eg.db
+ optdepends = r-pasillabamsubset
+ optdepends = r-rmarkdown
+ optdepends = r-tbx20bamsubset
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/APAlyzer_1.10.0.tar.gz
+ sha256sums = 004ce480ece61f5d605f4ce09b35757066eaac7dba9ffd02607caa3099913df6
+
+pkgname = r-apalyzer
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57f52a258d76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=APAlyzer
+_pkgver=1.10.0
+pkgname=r-${_pkgname,,}
+pkgver=1.10.0
+pkgrel=1
+pkgdesc='A toolkit for APA analysis using RNA-seq data'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('LGPL')
+depends=(
+ r
+ r-deseq2
+ r-dplyr
+ r-ensembldb
+ r-genomicalignments
+ r-genomicfeatures
+ r-genomicranges
+ r-ggplot2
+ r-ggrepel
+ r-repmis
+ r-rsamtools
+ r-rsubread
+ r-rtracklayer
+ r-summarizedexperiment
+ r-tidyr
+ r-variantannotation
+ r-hybridmtest
+)
+optdepends=(
+ r-annotationdbi
+ r-biocstyle
+ r-knitr
+ r-org.mm.eg.db
+ r-pasillabamsubset
+ r-rmarkdown
+ r-tbx20bamsubset
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('004ce480ece61f5d605f4ce09b35757066eaac7dba9ffd02607caa3099913df6')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: