summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 01:47:13 +0800
committerSukanka2022-06-06 01:47:13 +0800
commitba2afc65a9b49fc23a2093d1601e67132b17136e (patch)
tree38a6c1747ae686782a5cef3fc89695967ab06870
downloadaur-ba2afc65a9b49fc23a2093d1601e67132b17136e.tar.gz
add r-aroma.light
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f2c85fd4b94
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = r-aroma.light
+ pkgdesc = Light-Weight Methods for Normalization and Visualization of Microarray Data using Only Basic R Data Types
+ pkgver = 3.26.0
+ pkgrel = 3
+ url = https://bioconductor.org/packages/aroma.light
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-matrixstats
+ depends = r-r.methodss3
+ depends = r-r.oo
+ depends = r-r.utils
+ optdepends = r-princurve
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/aroma.light_3.26.0.tar.gz
+ sha256sums = da6fd263bcf8a66b8b6f09bc16a1360fc5c92c4c415794d22b4038bd79da8088
+
+pkgname = r-aroma.light
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..219ef95a9862
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=aroma.light
+_pkgver=3.26.0
+pkgname=r-${_pkgname,,}
+pkgver=3.26.0
+pkgrel=3
+pkgdesc='Light-Weight Methods for Normalization and Visualization of Microarray Data using Only Basic R Data Types'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-matrixstats
+ r-r.methodss3
+ r-r.oo
+ r-r.utils
+)
+optdepends=(
+ r-princurve
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('da6fd263bcf8a66b8b6f09bc16a1360fc5c92c4c415794d22b4038bd79da8088')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: