summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 01:50:51 +0800
committerSukanka2022-06-06 01:50:51 +0800
commitd6075000f7669618e1112db41e19994ac8331bd0 (patch)
treefcf0002250ed26fedf7bca50803525879376b74b
downloadaur-d6075000f7669618e1112db41e19994ac8331bd0.tar.gz
add r-arrow
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD57
2 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b1084127273
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = r-arrow
+ pkgdesc = Integration to 'Apache' 'Arrow'
+ pkgver = 8.0.0
+ pkgrel = 1
+ url = https://cran.r-project.org/package=arrow
+ arch = x86_64
+ license = Apache
+ depends = r
+ depends = r-assertthat
+ depends = r-bit64
+ depends = r-purrr
+ depends = r-r6
+ depends = r-rlang
+ depends = r-tidyselect
+ depends = r-vctrs
+ depends = gcc
+ depends = r-cpp11
+ optdepends = r-dbi
+ optdepends = r-dbplyr
+ optdepends = r-decor
+ optdepends = r-distro
+ optdepends = r-dplyr
+ optdepends = r-duckdb
+ optdepends = r-hms
+ optdepends = r-knitr
+ optdepends = r-lubridate
+ optdepends = r-pkgload
+ optdepends = r-reticulate
+ optdepends = r-rmarkdown
+ optdepends = r-stringi
+ optdepends = r-stringr
+ optdepends = r-testthat
+ optdepends = r-tibble
+ optdepends = r-withr
+ optdepends = libcurl-compat
+ optdepends = openssl
+ source = https://cran.r-project.org/src/contrib/arrow_8.0.0.tar.gz
+ sha256sums = 6c9aa08c68b7b39cb7d6b9394c0b94a566c0fe9a85cea61f5ed19e460bdb05ad
+
+pkgname = r-arrow
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..978e6f77ee9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# system requirements: C++11; for AWS S3 support on Linux, libcurl andopenssl (optional)
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=arrow
+_pkgver=8.0.0
+pkgname=r-${_pkgname,,}
+pkgver=8.0.0
+pkgrel=1
+pkgdesc="Integration to 'Apache' 'Arrow'"
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('Apache')
+depends=(
+ r
+ r-assertthat
+ r-bit64
+ r-purrr
+ r-r6
+ r-rlang
+ r-tidyselect
+ r-vctrs
+ gcc
+ r-cpp11
+)
+optdepends=(
+ r-dbi
+ r-dbplyr
+ r-decor
+ r-distro
+ r-dplyr
+ r-duckdb
+ r-hms
+ r-knitr
+ r-lubridate
+ r-pkgload
+ r-reticulate
+ r-rmarkdown
+ r-stringi
+ r-stringr
+ r-testthat
+ r-tibble
+ r-withr
+ libcurl-compat
+ openssl
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('6c9aa08c68b7b39cb7d6b9394c0b94a566c0fe9a85cea61f5ed19e460bdb05ad')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: