summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-03-09 01:57:30 +0300
committerViktor Drobot2020-03-09 01:57:30 +0300
commit8650683f42ac792e76ba5c0e04c69a204e441443 (patch)
tree8cbfeabc989fa3c4daf18e070ddd17b72ba1a487
parente02e85f699c9fafa16bb4abdb2770cb38641ec11 (diff)
downloadaur-8650683f42ac792e76ba5c0e04c69a204e441443.tar.gz
Fixed PKGBUILD
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD33
2 files changed, 26 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bce5bda8b59e..e2c19f873be8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = r-askpass
- pkgdesc = Cross-platform utilities for prompting the user for credentials or a passphrase.
+ pkgdesc = Safe Password Entry for R, Git, and SSH
pkgver = 1.1
- pkgrel = 2
+ pkgrel = 1
url = https://cran.r-project.org/package=askpass
+ arch = i686
arch = x86_64
license = MIT
+ makedepends = gcc
depends = r
- depends = r-sys
+ depends = r-sys>=2.1
+ optdepends = r-testthat
source = https://cran.r-project.org/src/contrib/askpass_1.1.tar.gz
md5sums = a00d6599ff99f501534c1d965a1fd3b4
diff --git a/PKGBUILD b/PKGBUILD
index 396528756809..033552de5b43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,30 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Kibouo <csonka.mihaly@hotmail.com>
+
_cranname=askpass
_cranver=1.1
-_pkgtar=${_cranname}_${_cranver}.tar.gz
-pkgname=r-askpass
+pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
-pkgrel=2
-pkgdesc='Cross-platform utilities for prompting the user for credentials or a passphrase.'
-arch=('x86_64')
+pkgrel=1
+pkgdesc="Safe Password Entry for R, Git, and SSH"
+arch=(i686 x86_64)
url="https://cran.r-project.org/package=${_cranname}"
-license=('MIT')
-depends=('r' 'r-sys')
-source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+license=(MIT)
+depends=(r 'r-sys>=2.1')
+makedepends=(gcc)
+optdepends=(r-testthat)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
md5sums=('a00d6599ff99f501534c1d965a1fd3b4')
-build(){
- R CMD INSTALL ${_pkgtar} -l $srcdir
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
}
+
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
-}
+ cd "${srcdir}"
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+}