summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Branham2018-05-30 09:07:08 -0500
committerAlex Branham2018-05-30 09:07:08 -0500
commit0681a688ffe75b3cb0124a6df9225a8b07c3e891 (patch)
tree082e8f45669a2e6369b455be38e3dec6af64f1ae
downloadaur-0681a688ffe75b3cb0124a6df9225a8b07c3e891.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2d3e1fbb3e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-assertthat
+ pkgdesc = Easy Pre and Post Assertions
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://cran.r-project.org/web/packages/assertthat/index.html
+ arch = any
+ license = GPL3
+ depends = r
+ optdepends = r-testthat
+ source = https://cran.r-project.org/src/contrib/assertthat_0.2.0.tar.gz
+ md5sums = 8134f0072c6a84fd738d3bfc5e7f68ef
+
+pkgname = r-assertthat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44055a37787a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alex Branham <branham@utexas.edu>
+_cranname=assertthat
+_cranver=0.2.0
+_pkgtar=${_cranname}_${_cranver}.tar.gz
+pkgname=r-assertthat
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="Easy Pre and Post Assertions"
+arch=('any')
+url="https://cran.r-project.org/web/packages/${_cranname}/index.html"
+license=('GPL3')
+depends=('r' )
+
+optdepends=('r-testthat')
+
+source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+md5sums=('8134f0072c6a84fd738d3bfc5e7f68ef')
+
+build(){
+ R CMD INSTALL ${_pkgtar} -l $srcdir
+}
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+}
+