summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 02:05:17 +0800
committerSukanka2022-06-06 02:05:17 +0800
commit691e27bc60eb956c76ece87a6b86d8d2c8721b82 (patch)
tree0d6fe9aed59624e76b0bc7a1103b600b1dbe6a14
downloadaur-691e27bc60eb956c76ece87a6b86d8d2c8721b82.tar.gz
add r-attract
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a1c9a248210
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = r-attract
+ pkgdesc = Methods to Find the Gene Expression Modules that Represent the Drivers of Kauffman's Attractor Landscape
+ pkgver = 1.48.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/attract
+ arch = any
+ license = LGPL
+ depends = r
+ depends = r-annotationdbi
+ depends = r-biobase
+ depends = r-gostats
+ depends = r-keggrest
+ depends = r-limma
+ depends = r-org.hs.eg.db
+ depends = r-reactome.db
+ optdepends = r-illuminahumanv1.db
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/attract_1.48.0.tar.gz
+ sha256sums = 0275e459dad7406068a3e32c0534ff28ff3105cf45e1f4f0eef64e74c4d62e38
+
+pkgname = r-attract
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7fdc629fa5fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=attract
+_pkgver=1.48.0
+pkgname=r-${_pkgname,,}
+pkgver=1.48.0
+pkgrel=1
+pkgdesc="Methods to Find the Gene Expression Modules that Represent the Drivers of Kauffman's Attractor Landscape"
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('LGPL')
+depends=(
+ r
+ r-annotationdbi
+ r-biobase
+ r-gostats
+ r-keggrest
+ r-limma
+ r-org.hs.eg.db
+ r-reactome.db
+)
+optdepends=(
+ r-illuminahumanv1.db
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('0275e459dad7406068a3e32c0534ff28ff3105cf45e1f4f0eef64e74c4d62e38')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: