summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 02:10:07 +0800
committerSukanka2022-06-06 02:10:07 +0800
commit283ec9f042e25493d859df751103d23e452ecb72 (patch)
tree94a095ffc0e8c8a4eb000c01559f5fb872bf3f87
downloadaur-283ec9f042e25493d859df751103d23e452ecb72.tar.gz
add r-baalchip
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD45
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a694828d3a99
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = r-baalchip
+ pkgdesc = BaalChIP: Bayesian analysis of allele-specific transcription factor binding in cancer genomes
+ pkgver = 1.22.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/BaalChIP
+ arch = any
+ license = Artistic2.0
+ depends = r
+ depends = r-coda
+ depends = r-doby
+ depends = r-doparallel
+ depends = r-foreach
+ depends = r-genomeinfodb
+ depends = r-genomicalignments
+ depends = r-genomicranges
+ depends = r-ggplot2
+ depends = r-iranges
+ depends = r-reshape2
+ depends = r-rsamtools
+ depends = r-scales
+ optdepends = r-biocgenerics
+ optdepends = r-biocstyle
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-runit
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/BaalChIP_1.22.0.tar.gz
+ sha256sums = d8bc23342aafb4023541fcf412ff88315d136b523046d97b72e579276c9a1c0b
+
+pkgname = r-baalchip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..842bcee30fb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=BaalChIP
+_pkgver=1.22.0
+pkgname=r-${_pkgname,,}
+pkgver=1.22.0
+pkgrel=1
+pkgdesc='BaalChIP: Bayesian analysis of allele-specific transcription factor binding in cancer genomes'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-coda
+ r-doby
+ r-doparallel
+ r-foreach
+ r-genomeinfodb
+ r-genomicalignments
+ r-genomicranges
+ r-ggplot2
+ r-iranges
+ r-reshape2
+ r-rsamtools
+ r-scales
+)
+optdepends=(
+ r-biocgenerics
+ r-biocstyle
+ r-knitr
+ r-rmarkdown
+ r-runit
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('d8bc23342aafb4023541fcf412ff88315d136b523046d97b72e579276c9a1c0b')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: