summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-06-07 09:04:40 +0100
committerGrey Christoforo2019-06-07 09:04:40 +0100
commita6a731fd0773f1d97277b0b5f1ceeefe510f0bd4 (patch)
tree10297332f95888ed3fb7dbf02bddaca7acaa8a62
parentb1eb3d33424d9c863a0cfb9ebd56b2d858b10307 (diff)
downloadaur-a6a731fd0773f1d97277b0b5f1ceeefe510f0bd4.tar.gz
initial commit
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 22 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5f3d58814d4..e5d0e1b6028b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = r-backports
pkgdesc = Reimplementations of Functions Introduced Since R-3.0.0
- pkgver = 1.1.2
+ pkgver = 1.1.4
pkgrel = 1
- url = https://cran.r-project.org/package=backports
+ url = http://cran.r-project.org/web/packages/backports/index.html
arch = x86_64
- license = GPL2
+ license = GPL3
depends = r
- source = https://cran.r-project.org/src/contrib/backports_1.1.2.tar.gz
- md5sums = 8554a095aefd1d294c2284df600c9323
+ depends = r-utils
+ source = http://cran.r-project.org/src/contrib/backports_1.1.4.tar.gz
+ md5sums = 0271f2897b4778c4f3a4c655da098257
pkgname = r-backports
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6ae0b18a1f6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 165ae71100fb..6937281efc27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,19 @@
-# Contributor: Ward Segers <w@rdsegers.be>
-# Contributor: Alex Branham <branham@utexas.edu>
-_cranname=backports
-_cranver=1.1.2
-_pkgtar=${_cranname}_${_cranver}.tar.gz
+# Contributor: Grey Christoforo <first name at last name dot net>
pkgname=r-backports
-pkgver=${_cranver//[:-]/.}
+_cran_name=backports
+pkgver=1.1.4
pkgrel=1
pkgdesc="Reimplementations of Functions Introduced Since R-3.0.0"
arch=('x86_64')
-url="https://cran.r-project.org/package=${_cranname}"
-license=('GPL2')
-depends=('r' )
+url="http://cran.r-project.org/web/packages/${_cran_name}/index.html"
+license=('GPL3')
+depends=('r' 'r-utils')
+source=("http://cran.r-project.org/src/contrib/${_cran_name}_${pkgver}.tar.gz")
+md5sums=('0271f2897b4778c4f3a4c655da098257')
-
-
-source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
-md5sums=('8554a095aefd1d294c2284df600c9323')
-
-build(){
- R CMD INSTALL ${_pkgtar} -l $srcdir
-}
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
-}
+ mkdir -p $pkgdir/usr/lib/R/library
+ cd $srcdir
+ R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_cran_name}
+}