summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 02:15:19 +0800
committerSukanka2022-06-06 02:15:19 +0800
commit79f645c57a0cd34f84351621b1ede4835ea9b6d5 (patch)
tree94de34f804023165ae2ac0fb39d9bb56eea43cf9
downloadaur-79f645c57a0cd34f84351621b1ede4835ea9b6d5.tar.gz
add r-bamsignals
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD41
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c53e11ae26a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = r-bamsignals
+ pkgdesc = Extract read count signals from bam files
+ pkgver = 1.28.0
+ pkgrel = 3
+ url = https://bioconductor.org/packages/bamsignals
+ arch = x86_64
+ license = GPL
+ depends = r
+ depends = r-biocgenerics
+ depends = r-genomicranges
+ depends = r-iranges
+ depends = r-rcpp
+ depends = r-rhtslib
+ depends = r-zlibbioc
+ depends = make
+ optdepends = r-biocstyle
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-rsamtools
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/bamsignals_1.28.0.tar.gz
+ sha256sums = 7ea6ee5fcbc6aa916771a271fa012adaed7e753ee79ab54a8694c12410ee8b7b
+
+pkgname = r-bamsignals
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37bea9e20a07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# system requirements: GNU make
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=bamsignals
+_pkgver=1.28.0
+pkgname=r-${_pkgname,,}
+pkgver=1.28.0
+pkgrel=3
+pkgdesc='Extract read count signals from bam files'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-biocgenerics
+ r-genomicranges
+ r-iranges
+ r-rcpp
+ r-rhtslib
+ r-zlibbioc
+ make
+)
+optdepends=(
+ r-biocstyle
+ r-knitr
+ r-rmarkdown
+ r-rsamtools
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('7ea6ee5fcbc6aa916771a271fa012adaed7e753ee79ab54a8694c12410ee8b7b')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: