summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-11-29 13:26:17 +0200
committerPekka Ristola2023-11-29 13:26:17 +0200
commit3f4974da63cc006c77a66f1e4d78e944afcebf7a (patch)
treeeeab2e82eb9ac9ecc6ab2c26e5c5e1204335a487
downloadaur-3f4974da63cc006c77a66f1e4d78e944afcebf7a.tar.gz
Version 1.4.0
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD54
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9a991e19368
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = r-basicstan
+ pkgdesc = Stan implementation of BASiCS
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/BASiCStan
+ arch = x86_64
+ license = GPL3
+ checkdepends = r-testthat
+ makedepends = r-bh
+ makedepends = r-rcppeigen
+ makedepends = r-stanheaders
+ depends = r-basics
+ depends = r-glmgampoi
+ depends = r-rcpp
+ depends = r-rcppparallel
+ depends = r-rstan
+ depends = r-rstantools
+ depends = r-scran
+ depends = r-scuttle
+ depends = r-singlecellexperiment
+ depends = r-summarizedexperiment
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/BASiCStan_1.4.0.tar.gz
+ md5sums = b7179ffcf510240c0c3cc6e8e31b60d7
+ sha256sums = 3176517994f10d6a9dd9571ae1d51d87e9ef2d5aed81da215b5a195ba516ea06
+
+pkgname = r-basicstan
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..608f4e71f04a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=BASiCStan
+_pkgver=1.4.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Stan implementation of BASiCS"
+arch=(x86_64)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(GPL3)
+depends=(
+ r-basics
+ r-glmgampoi
+ r-rcpp
+ r-rcppparallel
+ r-rstan
+ r-rstantools
+ r-scran
+ r-scuttle
+ r-singlecellexperiment
+ r-summarizedexperiment
+)
+makedepends=(
+ r-bh
+ r-rcppeigen
+ r-stanheaders
+)
+checkdepends=(
+ r-testthat
+)
+optdepends=(
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('b7179ffcf510240c0c3cc6e8e31b60d7')
+sha256sums=('3176517994f10d6a9dd9571ae1d51d87e9ef2d5aed81da215b5a195ba516ea06')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}