summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Branham2018-05-31 17:02:58 -0500
committerAlex Branham2018-05-31 17:02:58 -0500
commit30169014461a0ea9f09e6a6fa631f1f693067cec (patch)
tree8e9b9b1454d11b359a2dae3a60a8af252675ffda
downloadaur-30169014461a0ea9f09e6a6fa631f1f693067cec.tar.gz
Initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD26
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7d83136c7e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = r-bayesplot
+ pkgdesc = Plotting for Bayesian Models
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = https://cran.r-project.org/package=bayesplot
+ arch = any
+ license = GPL3
+ depends = r
+ depends = r-dplyr
+ depends = r-ggplot2
+ depends = r-reshape2
+ depends = r-rlang
+ depends = r-ggridges
+ optdepends = r-arm
+ optdepends = r-cran-gridextra
+ optdepends = r-knitr
+ optdepends = r-loo
+ optdepends = r-rmarkdown
+ optdepends = r-rstan
+ optdepends = r-rstanarm
+ optdepends = r-rstantools
+ optdepends = r-cran-scales
+ optdepends = r-shinystan
+ optdepends = r-testthat
+ optdepends = r-vdiffr
+ source = https://cran.r-project.org/src/contrib/bayesplot_1.5.0.tar.gz
+ md5sums = ec21c4e06aa23b4eaa8b52375d2e8854
+
+pkgname = r-bayesplot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b7819233411
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alex Branham <branham@utexas.edu>
+_cranname=bayesplot
+_cranver=1.5.0
+_pkgtar=${_cranname}_${_cranver}.tar.gz
+pkgname=r-bayesplot
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="Plotting for Bayesian Models"
+arch=('any')
+url="https://cran.r-project.org/package=${_cranname}"
+license=('GPL3')
+depends=('r' 'r-dplyr' 'r-ggplot2' 'r-reshape2' 'r-rlang' 'r-ggridges')
+
+optdepends=('r-arm' 'r-cran-gridextra' 'r-knitr' 'r-loo' 'r-rmarkdown' 'r-rstan' 'r-rstanarm' 'r-rstantools' 'r-cran-scales' 'r-shinystan' 'r-testthat' 'r-vdiffr')
+
+source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+md5sums=('ec21c4e06aa23b4eaa8b52375d2e8854')
+
+build(){
+ R CMD INSTALL ${_pkgtar} -l $srcdir
+}
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+}
+