summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 02:29:34 +0800
committerSukanka2022-06-06 02:29:34 +0800
commit4aafaf96a0289e3b4468dc6950acdee0051d7153 (patch)
tree2503327a597247071b190ac9b5ce78d9d556573c
downloadaur-4aafaf96a0289e3b4468dc6950acdee0051d7153.tar.gz
add r-bbotk
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD43
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94ecf258b390
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = r-bbotk
+ pkgdesc = Black-Box Optimization Toolkit
+ pkgver = 0.5.3
+ pkgrel = 1
+ url = https://cran.r-project.org/package=bbotk
+ arch = x86_64
+ license = LGPL
+ depends = r
+ depends = r-checkmate
+ depends = r-data.table
+ depends = r-lgr
+ depends = r-mlr3misc
+ depends = r-paradox
+ depends = r-r6
+ optdepends = r-adagio
+ optdepends = r-emoa
+ optdepends = r-gensa
+ optdepends = r-irace
+ optdepends = r-knitr
+ optdepends = r-nloptr
+ optdepends = r-progressr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://cran.r-project.org/src/contrib/bbotk_0.5.3.tar.gz
+ sha256sums = 641cde6587346b3eae3e331c2b10574d227e323887bb9c66da5547ac3d46128f
+
+pkgname = r-bbotk
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2f2481911f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=bbotk
+_pkgver=0.5.3
+pkgname=r-${_pkgname,,}
+pkgver=0.5.3
+pkgrel=1
+pkgdesc='Black-Box Optimization Toolkit'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('LGPL')
+depends=(
+ r
+ r-checkmate
+ r-data.table
+ r-lgr
+ r-mlr3misc
+ r-paradox
+ r-r6
+)
+optdepends=(
+ r-adagio
+ r-emoa
+ r-gensa
+ r-irace
+ r-knitr
+ r-nloptr
+ r-progressr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('641cde6587346b3eae3e331c2b10574d227e323887bb9c66da5547ac3d46128f')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: