summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 02:31:36 +0800
committerSukanka2022-06-06 02:31:36 +0800
commit57a2f9e64a730604edee368df90b2ab35a40ab31 (patch)
treebbd288a35df0862a8f0c48d6169d2a9dbb4b15db
downloadaur-57a2f9e64a730604edee368df90b2ab35a40ab31.tar.gz
add r-bdmmacorrect
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..293bd2b38211
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = r-bdmmacorrect
+ pkgdesc = Meta-analysis for the metagenomic read counts data from different cohorts
+ pkgver = 1.14.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/BDMMAcorrect
+ arch = x86_64
+ license = GPL
+ depends = r
+ depends = r-ape
+ depends = r-ellipse
+ depends = r-ggplot2
+ depends = r-rcpp
+ depends = r-rcpparmadillo
+ depends = r-rcppeigen
+ depends = r-summarizedexperiment
+ depends = r-vegan
+ optdepends = r-biocgenerics
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/BDMMAcorrect_1.14.0.tar.gz
+ sha256sums = 670e4096b3d35894641605bcd2b0959b06b63f020ba8ae07b9e7dba2449563a5
+
+pkgname = r-bdmmacorrect
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ffd5670cc13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=BDMMAcorrect
+_pkgver=1.14.0
+pkgname=r-${_pkgname,,}
+pkgver=1.14.0
+pkgrel=1
+pkgdesc='Meta-analysis for the metagenomic read counts data from different cohorts'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-ape
+ r-ellipse
+ r-ggplot2
+ r-rcpp
+ r-rcpparmadillo
+ r-rcppeigen
+ r-summarizedexperiment
+ r-vegan
+)
+optdepends=(
+ r-biocgenerics
+ r-knitr
+ r-rmarkdown
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('670e4096b3d35894641605bcd2b0959b06b63f020ba8ae07b9e7dba2449563a5')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: