summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 04:47:30 +0800
committerSukanka2022-06-06 04:47:30 +0800
commitef233747b6d13b7d45475df3aa8c5ca7477135ef (patch)
treed27407181d3e37000e495c2fcb8db51a64b47bf5
downloadaur-ef233747b6d13b7d45475df3aa8c5ca7477135ef.tar.gz
add r-bigmelon
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD44
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46cfa8301509
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = r-bigmelon
+ pkgdesc = Illumina methylation array analysis for large experiments
+ pkgver = 1.22.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/bigmelon
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-biobase
+ depends = r-biocgenerics
+ depends = r-gdsfmt
+ depends = r-geoquery
+ depends = r-illuminaio
+ depends = r-methylumi
+ depends = r-minfi
+ depends = r-watermelon
+ optdepends = r-biocgenerics
+ optdepends = r-biocstyle
+ optdepends = r-bumphunter
+ optdepends = r-illuminahumanmethylation450kanno.ilmn12.hg19
+ optdepends = r-illuminahumanmethylationepicanno.ilm10b2.hg19
+ optdepends = r-minfidata
+ optdepends = r-parallel
+ optdepends = r-runit
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/bigmelon_1.22.0.tar.gz
+ sha256sums = 53c0133043049887732071125743fa48f0d48cec03f0b5c0c66dbab830814cd7
+
+pkgname = r-bigmelon
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d85a058fd19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=bigmelon
+_pkgver=1.22.0
+pkgname=r-${_pkgname,,}
+pkgver=1.22.0
+pkgrel=1
+pkgdesc='Illumina methylation array analysis for large experiments'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-biobase
+ r-biocgenerics
+ r-gdsfmt
+ r-geoquery
+ r-illuminaio
+ r-methylumi
+ r-minfi
+ r-watermelon
+)
+optdepends=(
+ r-biocgenerics
+ r-biocstyle
+ r-bumphunter
+ r-illuminahumanmethylation450kanno.ilmn12.hg19
+ r-illuminahumanmethylationepicanno.ilm10b2.hg19
+ r-minfidata
+ r-parallel
+ r-runit
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('53c0133043049887732071125743fa48f0d48cec03f0b5c0c66dbab830814cd7')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: