summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 04:51:28 +0800
committerSukanka2022-06-06 04:51:28 +0800
commit5eeb5270e1506ba86fb3adf4dc941416cc17668d (patch)
tree8de0bdcb46f9f1149a07e50aaff450906bec0694
downloadaur-5eeb5270e1506ba86fb3adf4dc941416cc17668d.tar.gz
add r-bioassayr
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD44
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7ab6375ccf5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = r-bioassayr
+ pkgdesc = Cross-target analysis of small molecule bioactivity
+ pkgver = 1.34.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/bioassayR
+ arch = any
+ license = Artistic2.0
+ depends = r
+ depends = r-biocgenerics
+ depends = r-chemminer
+ depends = r-dbi
+ depends = r-rjson
+ depends = r-rsqlite
+ depends = r-xml
+ optdepends = r-biocstyle
+ optdepends = r-biomart
+ optdepends = r-cellhts2
+ optdepends = r-ggplot2
+ optdepends = r-knitcitations
+ optdepends = r-knitr
+ optdepends = r-knitrbootstrap
+ optdepends = r-rcurl
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/bioassayR_1.34.0.tar.gz
+ sha256sums = 3ff360da1e2ec93f6082a4f0404bcae3670f7f140b8388846298ccb74164797d
+
+pkgname = r-bioassayr
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..979ac7095d4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=bioassayR
+_pkgver=1.34.0
+pkgname=r-${_pkgname,,}
+pkgver=1.34.0
+pkgrel=1
+pkgdesc='Cross-target analysis of small molecule bioactivity'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-biocgenerics
+ r-chemminer
+ r-dbi
+ r-rjson
+ r-rsqlite
+ r-xml
+)
+optdepends=(
+ r-biocstyle
+ r-biomart
+ r-cellhts2
+ r-ggplot2
+ r-knitcitations
+ r-knitr
+ r-knitrbootstrap
+ r-rcurl
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('3ff360da1e2ec93f6082a4f0404bcae3670f7f140b8388846298ccb74164797d')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: