summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-11-29 13:27:44 +0200
committerPekka Ristola2023-11-29 13:27:44 +0200
commit3ebc4a22c299d2e998e9c0ebad6da7682e129851 (patch)
tree9755cde863eba6d3ce4277cd0bcd86145ef3b82f
downloadaur-3ebc4a22c299d2e998e9c0ebad6da7682e129851.tar.gz
Version 1.4.0
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD49
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fba9ad9c8532
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = r-biocfhir
+ pkgdesc = Illustration of FHIR ingestion and transformation using R
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/BiocFHIR
+ arch = any
+ license = Artistic2.0
+ checkdepends = r-testthat
+ depends = r-biocbaseutils
+ depends = r-dplyr
+ depends = r-dt
+ depends = r-graph
+ depends = r-jsonlite
+ depends = r-shiny
+ depends = r-tidyr
+ depends = r-visnetwork
+ optdepends = r-biocstyle
+ optdepends = r-igraph
+ optdepends = r-knitr
+ optdepends = r-rjsoncons
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/BiocFHIR_1.4.0.tar.gz
+ md5sums = 788951417cde10ad9434dd443db47f80
+ sha256sums = 7c181c170fc085c884ec4b1bc4a53cd402e18c2a99691a2ce5feb7799827d7eb
+
+pkgname = r-biocfhir
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49de09d769b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=BiocFHIR
+_pkgver=1.4.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Illustration of FHIR ingestion and transformation using R"
+arch=(any)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(Artistic2.0)
+depends=(
+ r-biocbaseutils
+ r-dplyr
+ r-dt
+ r-graph
+ r-jsonlite
+ r-shiny
+ r-tidyr
+ r-visnetwork
+)
+checkdepends=(
+ r-testthat
+)
+optdepends=(
+ r-biocstyle
+ r-igraph
+ r-knitr
+ r-rjsoncons
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('788951417cde10ad9434dd443db47f80')
+sha256sums=('7c181c170fc085c884ec4b1bc4a53cd402e18c2a99691a2ce5feb7799827d7eb')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla test.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}