summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2020-11-09 16:09:23 +0100
committerGrey Christoforo2020-11-09 16:09:23 +0100
commit4ce78f00a079d99bbaafa54926e3167adffbf509 (patch)
treefa36c89420a82f1ee5ee1386ab51ed36c7cade76
downloadaur-4ce78f00a079d99bbaafa54926e3167adffbf509.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD29
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..734a0e27a48f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = r-biocmanager
+ pkgdesc = BiocManager: Access the Bioconductor Project Package Repository
+ pkgver = 1.30.10
+ pkgrel = 1
+ url = https://bioconductor.org/packages/release/bioc/html/BiocManager.html
+ arch = x86_64
+ license = Artistic-2.0
+ depends = r
+ depends = r-knitr
+ depends = r-curl
+ depends = r-withr
+ depends = r-testthat
+ depends = r-remotes
+ optdepends = r-biocstyle
+ optdepends = r-biocversion
+ source = https://cran.r-project.org/src/contrib/BiocManager_1.30.10.tar.gz
+ sha256sums = f3b7a412b42be0ab8df5fcd9bf981876ba9e5c55bc5faaca7af7ede3b6d0c90e
+
+pkgname = r-biocmanager
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..27fd112126d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29aa850746f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Grey Christoforo <first name at last name dot net>
+
+_bcname=BiocManager
+_bcver=1.30.10
+pkgname=r-${_bcname,,}
+pkgver=${_bcver//[:-]/.}
+pkgrel=1
+pkgdesc="BiocManager: Access the Bioconductor Project Package Repository"
+arch=(x86_64)
+url="https://bioconductor.org/packages/release/bioc/html/${_bcname}.html"
+license=(Artistic-2.0)
+depends=(r r-knitr r-curl r-withr r-testthat r-remotes)
+optdepends=(r-biocstyle r-biocversion)
+source=("https://cran.r-project.org/src/contrib/${_bcname}_${_bcver}.tar.gz")
+sha256sums=('f3b7a412b42be0ab8df5fcd9bf981876ba9e5c55bc5faaca7af7ede3b6d0c90e')
+
+build(){
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_bcname}_${_bcver}.tar.gz -l ${srcdir}
+}
+
+package() {
+ cd "${srcdir}"
+
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_bcname}" "${pkgdir}/usr/lib/R/library"
+}
+