summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2023-03-26 18:55:50 +0300
committerChristoph Fink2023-03-26 18:55:50 +0300
commitf7ff0fd3e58b105ce3a1495df9a5df24964ea010 (patch)
treef45a714b2b061291e916d986ed19d633857741c8
parent54817890fae98c22c2b53b01dd3dd9b59eae2a71 (diff)
downloadaur-f7ff0fd3e58b105ce3a1495df9a5df24964ea010.tar.gz
upgpkg: r-biocmanager 1.30.20-3
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD36
2 files changed, 26 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8568973df04..e195cecbdf83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,11 @@
pkgbase = r-biocmanager
pkgdesc = A convenient tool to install and update Bioconductor packages.
pkgver = 1.30.20
- pkgrel = 2
+ pkgrel = 3
url = https://CRAN.R-project.org/package=BiocManager
arch = i686
arch = x86_64
license = Artistic2.0
- checkdepends = r-biocversion
- checkdepends = r-curl
- checkdepends = r-knitr
- checkdepends = r-remotes
- checkdepends = r-rmarkdown
- checkdepends = r-withr
- checkdepends = r-testthat>=3.0.0
depends = r
optdepends = r-biocversion
optdepends = r-curl
diff --git a/PKGBUILD b/PKGBUILD
index 9a85f92eb756..7dd124d44ac1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _cranname=BiocManager
_cranver=1.30.20
pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
-pkgrel=2
+pkgrel=3
pkgdesc="A convenient tool to install and update Bioconductor packages."
arch=("i686" "x86_64")
url="https://CRAN.R-project.org/package=${_cranname}"
@@ -21,28 +21,42 @@ optdepends=(
r-rmarkdown
r-withr
)
-checkdepends=(
- "${optdepends[@]}"
- "r-testthat>=3.0.0"
-)
+
+# The unittests for `r-biocmanager` have multiple circular
+# dependency chains.
+
+# As such, the tests can not be run on first build.
+# While R packages from CRAN, generally, are well-tested
+# before they are released, in some situations, you want to
+# have thorough testing on your own end.
+
+# To run the tests, first build this package without `check()`
+# (i.e., as-is) to bootstrap `r-biocmanager`. Then, on subsequent builds,
+# (assumining you have a local repository that is accessible from
+# the build chroot), uncomment the lines defining `checkdepends`, below,
+# as well as the `check()` function further down
+
+# checkdepends=(
+# "${optdepends[@]}"
+# "r-testthat>=3.0.0"
+# )
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-b2sums=('f70c66f07d361d80f2679af273b9b948cf492ab5ef138dc552b264c462e30c602a3324bda346b181663e2e9f492e432ea48d7e995e311e51dfd98e3519e4a03c')
+b2sums=("f70c66f07d361d80f2679af273b9b948cf492ab5ef138dc552b264c462e30c602a3324bda346b181663e2e9f492e432ea48d7e995e311e51dfd98e3519e4a03c")
build() {
mkdir -p "${srcdir}/build/"
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
-check() {
- cd "${srcdir}/${_cranname}/tests"
- R_LIBS="${srcdir}/build/" Rscript --vanilla testthat.R
-}
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual "${_cranname}"
+# }
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
cp -a --no-preserve=ownership "${srcdir}/build/${_cranname}" "${pkgdir}/usr/lib/R/library"
-
if [[ -f "${_cranname}/LICENSE" ]]; then
install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
fi