summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-09-22 18:05:57 +0000
committerBioArchLinuxBot2023-09-22 18:05:57 +0000
commite96216ceb27e7f70bd9c4e52332811c3b9ff5a41 (patch)
treeac37d4620d5df4f5fe285567fb2dd467185688ef
parent3d39e8e513e35edb8ff9359f1f89882cbfede333 (diff)
downloadaur-e96216ceb27e7f70bd9c4e52332811c3b9ff5a41.tar.gz
[lilac] updated to 1.8.1-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
2 files changed, 33 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29242e48f953..8db2031491d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = r-biodb
pkgdesc = biodb, a library and a development framework for connecting to chemical and biological databases
- pkgver = 1.8.0
+ pkgver = 1.8.1
pkgrel = 1
url = https://bioconductor.org/packages/biodb
arch = x86_64
- license = AGPL
- depends = r
+ license = AGPL3
+ checkdepends = r-xml2
+ makedepends = r-testthat
depends = r-biocfilecache
depends = r-chk
+ depends = r-git2r
depends = r-jsonlite
depends = r-lgr
depends = r-lifecycle
@@ -20,20 +22,19 @@ pkgbase = r-biodb
depends = r-rcurl
depends = r-rsqlite
depends = r-stringr
- depends = r-testthat
depends = r-withr
depends = r-xml
depends = r-yaml
optdepends = r-biocstyle
optdepends = r-covr
optdepends = r-devtools
- optdepends = r-git2r
optdepends = r-knitr
optdepends = r-rmarkdown
optdepends = r-roxygen2
optdepends = r-testthat
optdepends = r-xml2
- source = https://bioconductor.org/packages/release/bioc/src/contrib/biodb_1.8.0.tar.gz
- sha256sums = b394a2bea684f3c406cbdb5564893dc289ad995716cf8cf13d0c66e57ec092d1
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/biodb_1.8.1.tar.gz
+ md5sums = f69fe1c97541bcf6b7a21503029dca6e
+ sha256sums = 93fd88720be908517d594ab00b24d98a994edee00efd7f311664e182540547a2
pkgname = r-biodb
diff --git a/PKGBUILD b/PKGBUILD
index 3f4b6a347df1..25e029344810 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
-# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=biodb
-_pkgver=1.8.0
+_pkgver=1.8.1
pkgname=r-${_pkgname,,}
-pkgver=1.8.0
+pkgver=${_pkgver//-/.}
pkgrel=1
-pkgdesc='biodb, a library and a development framework for connecting to chemical and biological databases'
-arch=('x86_64')
+pkgdesc="biodb, a library and a development framework for connecting to chemical and biological databases"
+arch=(x86_64)
url="https://bioconductor.org/packages/${_pkgname}"
-license=('AGPL')
+license=(AGPL3)
depends=(
- r
r-biocfilecache
r-chk
+ r-git2r
r-jsonlite
r-lgr
r-lifecycle
@@ -25,16 +26,20 @@ depends=(
r-rcurl
r-rsqlite
r-stringr
- r-testthat
r-withr
r-xml
r-yaml
)
+makedepends=(
+ r-testthat
+)
+checkdepends=(
+ r-xml2
+)
optdepends=(
r-biocstyle
r-covr
r-devtools
- r-git2r
r-knitr
r-rmarkdown
r-roxygen2
@@ -42,14 +47,20 @@ optdepends=(
r-xml2
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('b394a2bea684f3c406cbdb5564893dc289ad995716cf8cf13d0c66e57ec092d1')
+md5sums=('f69fe1c97541bcf6b7a21503029dca6e')
+sha256sums=('93fd88720be908517d594ab00b24d98a994edee00efd7f311664e182540547a2')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: