summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel H. Neilson2021-06-08 09:26:54 -0400
committerDaniel H. Neilson2021-06-08 09:26:54 -0400
commitde27c7cd3a92407ace5f9b3f87c2942da1d17d5f (patch)
treeee6659c7dae927952dce6179fe5f20c0d84f42bf
downloadaur-de27c7cd3a92407ace5f9b3f87c2942da1d17d5f.tar.gz
Create r-bis package
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD24
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ce2b4cd7c9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = r-bis
+ pkgdesc = Provides an interface to data provided by the Bank for International Settlements, allowing for programmatic retrieval of a large quantity of (central) banking data.
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://cran.r-project.org/web/packages/BIS/
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-dplyr
+ depends = r-readr
+ depends = r-tidyr
+ depends = r-rvest
+ depends = r-xml2
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-ggplot2
+ optdepends = r-zoo
+ source = https://cran.r-project.org/src/contrib/BIS_0.2.1.tar.gz
+ sha512sums = c5bd657aa942a6793f9149ece9929f8f19ec9707fd093b49e8ccb1d666f4a39088057cda513c2b2474003615b0f15abe91a83eec3c028da0071dd6e9c8ab1b21
+
+pkgname = r-bis
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8494b0927539
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: dhn <neilson+aur@sent.com>
+
+_pkgname=BIS
+pkgname=r-bis
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="Provides an interface to data provided by the Bank for International Settlements, allowing for programmatic retrieval of a large quantity of (central) banking data."
+arch=('any')
+url="https://cran.r-project.org/web/packages/$_pkgname/"
+license=('GPL')
+depends=('r' 'r-dplyr' 'r-readr' 'r-tidyr' 'r-rvest' 'r-xml2')
+makedepends=()
+optdepends=('r-knitr' 'r-rmarkdown' 'r-ggplot2' 'r-zoo')
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_$pkgver.tar.gz")
+sha512sums=('c5bd657aa942a6793f9149ece9929f8f19ec9707fd093b49e8ccb1d666f4a39088057cda513c2b2474003615b0f15abe91a83eec3c028da0071dd6e9c8ab1b21')
+
+build(){
+ R CMD INSTALL ${_pkgname}_$pkgver.tar.gz -l "$srcdir"
+}
+
+package() {
+ install -dm 755 "$pkgdir"/usr/lib/R/library
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}