summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 05:18:14 +0800
committerSukanka2022-06-06 05:18:14 +0800
commit41a4047c414e4f03045cf51707849b0844219de5 (patch)
tree0ed0f0c148b9167ac9f97b88552f76f4e9ac9076
downloadaur-41a4047c414e4f03045cf51707849b0844219de5.tar.gz
add r-bootnet
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD54
2 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..59c7d72aa266
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = r-bootnet
+ pkgdesc = Bootstrap Methods for Various Network Estimation Routines
+ pkgver = 1.5
+ pkgrel = 1
+ url = https://cran.r-project.org/package=bootnet
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-abind
+ depends = r-corpcor
+ depends = r-dplyr
+ depends = r-ggplot2
+ depends = r-gtools
+ depends = r-igraph
+ depends = r-isingfit
+ depends = r-isingsampler
+ depends = r-mgm
+ depends = r-mvtnorm
+ depends = r-networktoolbox
+ depends = r-networktools
+ depends = r-pbapply
+ depends = r-qgraph
+ depends = r-rlang
+ depends = r-snow
+ depends = r-tibble
+ depends = r-tidyr
+ optdepends = r-bdgraph
+ optdepends = r-ggmncv
+ optdepends = r-glasso
+ optdepends = r-graphicalvar
+ optdepends = r-huge
+ optdepends = r-lavaan
+ optdepends = r-psychtools
+ optdepends = r-relaimpo
+ source = https://cran.r-project.org/src/contrib/bootnet_1.5.tar.gz
+ sha256sums = 118e35c3de19001508e9508a5678e9d358b9c8ef6890e4c79a33fa5444aeee8e
+
+pkgname = r-bootnet
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e241cc86b64
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: sukanka <su975853527@gmail.com>
+
+_pkgname=bootnet
+_pkgver=1.5
+pkgname=r-${_pkgname,,}
+pkgver=1.5
+pkgrel=1
+pkgdesc='Bootstrap Methods for Various Network Estimation Routines'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-abind
+ r-corpcor
+ r-dplyr
+ r-ggplot2
+ r-gtools
+ r-igraph
+ r-isingfit
+ r-isingsampler
+ r-mgm
+ r-mvtnorm
+ r-networktoolbox
+ r-networktools
+ r-pbapply
+ r-qgraph
+ r-rlang
+ r-snow
+ r-tibble
+ r-tidyr
+)
+optdepends=(
+ r-bdgraph
+ r-ggmncv
+ r-glasso
+ r-graphicalvar
+ r-huge
+ r-lavaan
+ r-psychtools
+ r-relaimpo
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('118e35c3de19001508e9508a5678e9d358b9c8ef6890e4c79a33fa5444aeee8e')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: