summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-12-11 16:47:11 +0200
committerPekka Ristola2023-12-11 16:47:11 +0200
commitdf525e1f7e0adf709639020557a00a14076893a5 (patch)
tree08a2c16dad7facfac4fbe4f11a7c1ee80401d56f
downloadaur-df525e1f7e0adf709639020557a00a14076893a5.tar.gz
Version 1.0.5
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e61a48937e3b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = r-brisc
+ pkgdesc = Fast Inference for Large Spatial Datasets using BRISC
+ pkgver = 1.0.5
+ pkgrel = 1
+ url = https://cran.r-project.org/package=BRISC
+ arch = x86_64
+ license = GPL
+ depends = blas
+ depends = lapack
+ depends = r-matrixstats
+ depends = r-pbapply
+ depends = r-rann
+ depends = r-rdist
+ source = https://cran.r-project.org/src/contrib/BRISC_1.0.5.tar.gz
+ md5sums = c82f874ae549ae510030a8c6735bccc2
+ sha256sums = 89e44bf9f684c948c3c581c732fe8b4b27607e7506e3948dc4da3eca06a8f71a
+
+pkgname = r-brisc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a5425829138
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=BRISC
+_pkgver=1.0.5
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Fast Inference for Large Spatial Datasets using BRISC"
+arch=(x86_64)
+url="https://cran.r-project.org/package=${_pkgname}"
+license=(GPL)
+depends=(
+ blas
+ lapack
+ r-matrixstats
+ r-pbapply
+ r-rann
+ r-rdist
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('c82f874ae549ae510030a8c6735bccc2')
+sha256sums=('89e44bf9f684c948c3c581c732fe8b4b27607e7506e3948dc4da3eca06a8f71a')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}