summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 05:43:11 +0800
committerSukanka2022-06-06 05:43:11 +0800
commitf65f1ff43af91eff86d8a382f2687a082978b0a4 (patch)
treebc6d4af1d9fa3947ff3e2c42f9ea8dc980f24cb0
downloadaur-f65f1ff43af91eff86d8a382f2687a082978b0a4.tar.gz
add r-candisc
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9ca6cf26b4e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = r-candisc
+ pkgdesc = Visualizing Generalized Canonical Discriminant and Canonical Correlation Analysis
+ pkgver = 0.8.6
+ pkgrel = 4
+ url = https://cran.r-project.org/package=candisc
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-car
+ depends = r-heplots
+ optdepends = r-corrplot
+ optdepends = r-knitr
+ optdepends = r-mass
+ optdepends = r-rgl
+ optdepends = r-rmarkdown
+ optdepends = r-rpart
+ optdepends = r-rpart.plot
+ source = https://cran.r-project.org/src/contrib/candisc_0.8-6.tar.gz
+ sha256sums = 9645a3c0f8a0f7ee1e0c4de6cac4d3432177e6d3975fa538cdb060f5e480709d
+
+pkgname = r-candisc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7a3f54e0a2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: sukanka <su975853527@gmail.com>
+
+_pkgname=candisc
+_pkgver=0.8-6
+pkgname=r-${_pkgname,,}
+pkgver=0.8.6
+pkgrel=4
+pkgdesc='Visualizing Generalized Canonical Discriminant and Canonical Correlation Analysis'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-car
+ r-heplots
+)
+optdepends=(
+ r-corrplot
+ r-knitr
+ r-mass
+ r-rgl
+ r-rmarkdown
+ r-rpart
+ r-rpart.plot
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('9645a3c0f8a0f7ee1e0c4de6cac4d3432177e6d3975fa538cdb060f5e480709d')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: