summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2021-12-05 21:42:04 +0300
committerViktor Drobot2021-12-05 21:42:04 +0300
commitc90567ca687067323b4f86caadb9cc3ca3c17c56 (patch)
tree38f9dddc1d07cee23e9ddb61cc11ba04ae4152da
parentb17e879c214335ac7768c3b581d0ca19ff131317 (diff)
downloadaur-c90567ca687067323b4f86caadb9cc3ca3c17c56.tar.gz
Fix PKGBUILD
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 6 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc5679280bd6..7abd2cda4171 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,9 +6,8 @@ pkgbase = r-cardata
arch = any
license = GPL2
license = GPL3
- depends = r
+ depends = r>=3.5.0
source = https://cran.r-project.org/src/contrib/carData_3.0-4.tar.gz
- md5sums = e41712fe4583c13f129894150019b014
+ sha256sums = cda6f5e3efc1d955a4a0625e9c33f90d49f5455840e88b3bd757129b86044724
pkgname = r-cardata
-
diff --git a/PKGBUILD b/PKGBUILD
index d6bec7fb068f..a81d00313827 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,19 +10,16 @@ pkgdesc="Companion to Applied Regression Data Sets"
arch=(any)
url="https://cran.r-project.org/package=${_cranname}"
license=(GPL2 GPL3)
-depends=(r)
+depends=('r>=3.5.0')
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-md5sums=('e41712fe4583c13f129894150019b014')
+sha256sums=('cda6f5e3efc1d955a4a0625e9c33f90d49f5455840e88b3bd757129b86044724')
build() {
- cd "${srcdir}"
-
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
}
package() {
- cd "${srcdir}"
-
install -dm0755 "${pkgdir}/usr/lib/R/library"
+
cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}