summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-11-29 13:36:01 +0200
committerPekka Ristola2023-11-29 13:36:01 +0200
commit48c3d09fcf43b904f7e3db8864d7773023549b13 (patch)
treea113c90bd507043f48d7a877e69648e6fecd3729
downloadaur-48c3d09fcf43b904f7e3db8864d7773023549b13.tar.gz
Version 1.4.0
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD54
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..222f71d7f8ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = r-cardelino
+ pkgdesc = Clone Identification from Single Cell Data
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/cardelino
+ arch = any
+ license = GPL3
+ checkdepends = r-testthat
+ depends = r-combinat
+ depends = r-genomeinfodb
+ depends = r-genomicranges
+ depends = r-ggplot2
+ depends = r-ggtree
+ depends = r-matrixstats
+ depends = r-pheatmap
+ depends = r-s4vectors
+ depends = r-snpstats
+ depends = r-variantannotation
+ depends = r-vcfr
+ optdepends = r-biocstyle
+ optdepends = r-foreach
+ optdepends = r-knitr
+ optdepends = r-pcamethods
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ optdepends = r-vgam
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/cardelino_1.4.0.tar.gz
+ md5sums = 363c06547419f29e1cdfe473651e1861
+ sha256sums = f6ed2a646b833f4a63b0641731ce2c1dbc4718d76d7418c0878acb00561b8d78
+
+pkgname = r-cardelino
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f2f6c45d1fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=cardelino
+_pkgver=1.4.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Clone Identification from Single Cell Data"
+arch=(any)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(GPL3)
+depends=(
+ r-combinat
+ r-genomeinfodb
+ r-genomicranges
+ r-ggplot2
+ r-ggtree
+ r-matrixstats
+ r-pheatmap
+ r-s4vectors
+ r-snpstats
+ r-variantannotation
+ r-vcfr
+)
+checkdepends=(
+ r-testthat
+)
+optdepends=(
+ r-biocstyle
+ r-foreach
+ r-knitr
+ r-pcamethods
+ r-rmarkdown
+ r-testthat
+ r-vgam
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('363c06547419f29e1cdfe473651e1861')
+sha256sums=('f6ed2a646b833f4a63b0641731ce2c1dbc4718d76d7418c0878acb00561b8d78')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}