summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaulius Lukauskas2015-08-05 11:47:26 +0100
committerSaulius Lukauskas2015-08-05 11:47:26 +0100
commit990298e07c42291dec39bb2a9afb4bd25d6b460f (patch)
tree0a163149b1a889bb2705a5d2c940f3182dbd56cf
downloadaur-990298e07c42291dec39bb2a9afb4bd25d6b460f.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..909b53288f54
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-catools
+ pkgdesc = Moving (rolling, running) window statistic functions, read/write for GIF and ENVI binary files, fast calculation of AUC, LogitBoost classifier, base64 encoder/decoder, round-off-error-free sum and cumsum, etc.
+ pkgver = 1.17.1
+ pkgrel = 1
+ url = http://cran.r-project.org/web/packages/caTools/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = r
+ source = http://cran.r-project.org/src/contrib/caTools_1.17.1.tar.gz
+ md5sums = 5c872bbc78b177b306f36709deb44498
+
+pkgname = r-catools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9cebc28d5da7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Contributor: Sauliusl <luksaulius at gmail>
+# Based on r-colorspace PKGBUILD
+pkgname=r-catools
+pkgver=1.17.1
+pkgrel=1
+pkgdesc="Moving (rolling, running) window statistic functions, read/write for GIF and ENVI binary files, fast calculation of AUC, LogitBoost classifier, base64 encoder/decoder, round-off-error-free sum and cumsum, etc."
+arch=('i686' 'x86_64')
+url="http://cran.r-project.org/web/packages/caTools/index.html"
+license=('GPL3')
+depends=('r')
+source=("http://cran.r-project.org/src/contrib/caTools_${pkgver}.tar.gz")
+md5sums=('5c872bbc78b177b306f36709deb44498')
+
+package() {
+ mkdir -p $pkgdir/usr/lib/R/library
+ cd $srcdir
+
+ R CMD INSTALL -l $pkgdir/usr/lib/R/library ./caTools
+}