summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 05:51:27 +0800
committerSukanka2022-06-06 05:51:27 +0800
commit491342c4331d54c1f3dfc825b85c45482f320987 (patch)
tree928aeaf47214a2e1c12867ef121ee198fa8d2ac8
downloadaur-491342c4331d54c1f3dfc825b85c45482f320987.tar.gz
add r-ccfindr
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD44
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63caafaf9960
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = r-ccfindr
+ pkgdesc = Cancer Clone Finder
+ pkgver = 1.16.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/ccfindR
+ arch = x86_64
+ license = GPL
+ depends = gsl
+ depends = r
+ depends = r-ape
+ depends = r-gtools
+ depends = r-irlba
+ depends = r-rcolorbrewer
+ depends = r-rcpp
+ depends = r-rcppeigen
+ depends = r-rdpack
+ depends = r-rmpi
+ depends = r-rtsne
+ depends = r-s4vectors
+ depends = r-singlecellexperiment
+ depends = r-summarizedexperiment
+ optdepends = r-biocstyle
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/ccfindR_1.16.0.tar.gz
+ sha256sums = 3bdaffd17816f6facfa99a8e6ef7c2948fa2ff1a3e863a267960c38e1128e5bd
+
+pkgname = r-ccfindr
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a34b12ba0cd4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=ccfindR
+_pkgver=1.16.0
+pkgname=r-${_pkgname,,}
+pkgver=1.16.0
+pkgrel=1
+pkgdesc='Cancer Clone Finder'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ gsl
+ r
+ r-ape
+ r-gtools
+ r-irlba
+ r-rcolorbrewer
+ r-rcpp
+ r-rcppeigen
+ r-rdpack
+ r-rmpi
+ r-rtsne
+ r-s4vectors
+ r-singlecellexperiment
+ r-summarizedexperiment
+)
+optdepends=(
+ r-biocstyle
+ r-knitr
+ r-rmarkdown
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('3bdaffd17816f6facfa99a8e6ef7c2948fa2ff1a3e863a267960c38e1128e5bd')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: