summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-11-29 13:37:15 +0200
committerPekka Ristola2023-11-29 13:37:15 +0200
commitcb7985d88962d3446b4dee4c5f13f677956f9717 (patch)
tree33b7fae659448d41efeba8a8d6a20951b6945ede
downloadaur-cb7985d88962d3446b4dee4c5f13f677956f9717.tar.gz
Version 1.4.0
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD52
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85a95dccbc9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = r-ccimpute
+ pkgdesc = ccImpute: an accurate and scalable consensus clustering based approach to impute dropout events in the single-cell RNA-seq data (https://doi.org/10.1186/s12859-022-04814-8)
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/ccImpute
+ arch = x86_64
+ license = GPL3
+ checkdepends = r-testthat
+ makedepends = r-rcppeigen
+ depends = r-biocparallel
+ depends = r-matrixstats
+ depends = r-rcpp
+ depends = r-simlr
+ optdepends = r-biocstyle
+ optdepends = r-knitr
+ optdepends = r-mclust
+ optdepends = r-rmarkdown
+ optdepends = r-scater
+ optdepends = r-scrnaseq
+ optdepends = r-sessioninfo
+ optdepends = r-singlecellexperiment
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/ccImpute_1.4.0.tar.gz
+ md5sums = f402177e3fc7bbbcac504c956889dfa9
+ sha256sums = 12728b12c2f470112c7a3108a6f999d798d67e07f892c75f08571c6462f2476c
+
+pkgname = r-ccimpute
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b76b50d3227
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=ccImpute
+_pkgver=1.4.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="ccImpute: an accurate and scalable consensus clustering based approach to impute dropout events in the single-cell RNA-seq data (https://doi.org/10.1186/s12859-022-04814-8)"
+arch=(x86_64)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(GPL3)
+depends=(
+ r-biocparallel
+ r-matrixstats
+ r-rcpp
+ r-simlr
+)
+makedepends=(
+ r-rcppeigen
+)
+checkdepends=(
+ r-testthat
+)
+optdepends=(
+ r-biocstyle
+ r-knitr
+ r-mclust
+ r-rmarkdown
+ r-scater
+ r-scrnaseq
+ r-sessioninfo
+ r-singlecellexperiment
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('f402177e3fc7bbbcac504c956889dfa9')
+sha256sums=('12728b12c2f470112c7a3108a6f999d798d67e07f892c75f08571c6462f2476c')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}