summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-02-13 18:04:16 +0000
committerBioArchLinuxBot2024-02-13 18:04:16 +0000
commit1846d21b1cd25331dfd015c247888160e48e42cc (patch)
tree48c97f47826a1c7467ae534ab074e407306fa305
parent3a1acce7916d75b57f5b43a4404d74d9ec6d9d97 (diff)
downloadaur-1846d21b1cd25331dfd015c247888160e48e42cc.tar.gz
[lilac] updated to 1.24.0-2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD26
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f044a12da4d..3796981d1df8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = r-cellscape
pkgdesc = Explores single cell copy number profiles in the context of a single cell tree
pkgver = 1.24.0
- pkgrel = 1
+ pkgrel = 2
url = https://bioconductor.org/packages/cellscape
arch = any
- license = GPL
- depends = r
+ license = GPL-3.0-only
depends = r-dplyr
depends = r-gtools
depends = r-htmlwidgets
@@ -15,7 +14,8 @@ pkgbase = r-cellscape
depends = r-stringr
optdepends = r-knitr
optdepends = r-rmarkdown
- source = https://bioconductor.org/packages/release/bioc/src/contrib/cellscape_1.24.0.tar.gz
- sha256sums = 4c3d82b3d8938f0e22797db3c0ea9c047afb4f2a646f6304eaadf6a39157fc3c
+ source = https://bioconductor.org/packages/3.17/bioc/src/contrib/cellscape_1.24.0.tar.gz
+ md5sums = 7df865c4752c43a3745b01f93654a00a
+ b2sums = bf465c04a58beaef4f43856afce370abf722489eec6267b2f36e3b5a925a2e74eadb052662ceeb9f073174727f4ae69e256c4f60ae72fa147f09c88e248c203d
pkgname = r-cellscape
diff --git a/PKGBUILD b/PKGBUILD
index c3f004ce213d..10b831687dae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,13 @@
_pkgname=cellscape
_pkgver=1.24.0
pkgname=r-${_pkgname,,}
-pkgver=1.24.0
-pkgrel=1
-pkgdesc='Explores single cell copy number profiles in the context of a single cell tree'
-arch=('any')
-url="https://bioconductor.org/packages/${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="Explores single cell copy number profiles in the context of a single cell tree"
+arch=(any)
+url="https://bioconductor.org/packages/$_pkgname"
+license=('GPL-3.0-only')
depends=(
- r
r-dplyr
r-gtools
r-htmlwidgets
@@ -23,15 +22,16 @@ optdepends=(
r-knitr
r-rmarkdown
)
-source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('4c3d82b3d8938f0e22797db3c0ea9c047afb4f2a646f6304eaadf6a39157fc3c')
+source=("https://bioconductor.org/packages/3.17/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('7df865c4752c43a3745b01f93654a00a')
+b2sums=('bf465c04a58beaef4f43856afce370abf722489eec6267b2f36e3b5a925a2e74eadb052662ceeb9f073174727f4ae69e256c4f60ae72fa147f09c88e248c203d')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: