summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 06:00:03 +0800
committerSukanka2022-06-06 06:00:03 +0800
commitc351bab90ff5bd1b609b1a13b8e5ec8a5a4396e2 (patch)
tree04aa447178ba4e37e9e06b58505886c30916101a
downloadaur-c351bab90ff5bd1b609b1a13b8e5ec8a5a4396e2.tar.gz
add r-cellscape
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2afc2dab214
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = r-cellscape
+ pkgdesc = Explores single cell copy number profiles in the context of a single cell tree
+ pkgver = 1.20.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/cellscape
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-dplyr
+ depends = r-gtools
+ depends = r-htmlwidgets
+ depends = r-jsonlite
+ depends = r-plyr
+ depends = r-reshape2
+ depends = r-stringr
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/cellscape_1.20.0.tar.gz
+ sha256sums = 1aeeb7b3e82aa26a9cffff61a7c731555a81e9556609f235f19d8f46b83e1fcc
+
+pkgname = r-cellscape
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f1ea9edb7a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=cellscape
+_pkgver=1.20.0
+pkgname=r-${_pkgname,,}
+pkgver=1.20.0
+pkgrel=1
+pkgdesc='Explores single cell copy number profiles in the context of a single cell tree'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-dplyr
+ r-gtools
+ r-htmlwidgets
+ r-jsonlite
+ r-plyr
+ r-reshape2
+ r-stringr
+)
+optdepends=(
+ r-knitr
+ r-rmarkdown
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('1aeeb7b3e82aa26a9cffff61a7c731555a81e9556609f235f19d8f46b83e1fcc')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: