summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-07-04 23:39:17 +0300
committerPekka Ristola2023-07-04 23:39:17 +0300
commitb4990f4561abfda818b3bd002a67cc66a85d2a03 (patch)
tree73152b22e87be343962e774f77b43113a5085c0a
downloadaur-b4990f4561abfda818b3bd002a67cc66a85d2a03.tar.gz
Version 1.1.5
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d53a60bc34d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = r-chandwich
+ pkgdesc = Chandler-Bate Sandwich Loglikelihood Adjustment
+ pkgver = 1.1.5
+ pkgrel = 1
+ url = https://cran.r-project.org/package=chandwich
+ arch = any
+ license = GPL
+ checkdepends = r-testthat
+ depends = r-numderiv
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-sandwich
+ optdepends = r-testthat
+ source = https://cran.r-project.org/src/contrib/chandwich_1.1.5.tar.gz
+ md5sums = 34e8977a6e7b3939dc60976f4bafbd3f
+ sha256sums = 78ebea16f252731e615b625db16b5b8c95869e98a91b355c896348b2e2786fc4
+
+pkgname = r-chandwich
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c3b6c820e23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=chandwich
+_pkgver=1.1.5
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Chandler-Bate Sandwich Loglikelihood Adjustment"
+arch=(any)
+url="https://cran.r-project.org/package=${_pkgname}"
+license=(GPL)
+depends=(
+ r-numderiv
+)
+checkdepends=(
+ r-testthat
+)
+optdepends=(
+ r-knitr
+ r-rmarkdown
+ r-sandwich
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('34e8977a6e7b3939dc60976f4bafbd3f')
+sha256sums=('78ebea16f252731e615b625db16b5b8c95869e98a91b355c896348b2e2786fc4')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}