summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 06:19:37 +0800
committerSukanka2022-06-06 06:19:37 +0800
commitb130d9200b563ba123821f742c717078c6f9c976 (patch)
tree17742445b8417ef2c9423dcf204889910bd69317
downloadaur-b130d9200b563ba123821f742c717078c6f9c976.tar.gz
add r-chromscape
-rw-r--r--.SRCINFO67
-rw-r--r--PKGBUILD83
2 files changed, 150 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f85e308c30c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,67 @@
+pkgbase = r-chromscape
+ pkgdesc = Analysis of single-cell epigenomics datasets with a Shiny App
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/ChromSCape
+ arch = x86_64
+ license = GPL
+ depends = r
+ depends = r-batchelor
+ depends = r-biocparallel
+ depends = r-colorramps
+ depends = r-colourpicker
+ depends = r-consensusclusterplus
+ depends = r-coop
+ depends = r-delayedarray
+ depends = r-dplyr
+ depends = r-dt
+ depends = r-edger
+ depends = r-forcats
+ depends = r-fs
+ depends = r-genomicranges
+ depends = r-ggplot2
+ depends = r-iranges
+ depends = r-irlba
+ depends = r-jsonlite
+ depends = r-kableextra
+ depends = r-matrixtests
+ depends = r-msigdbr
+ depends = r-plotly
+ depends = r-qs
+ depends = r-qualv
+ depends = r-rcpp
+ depends = r-rlist
+ depends = r-rsamtools
+ depends = r-rtracklayer
+ depends = r-rtsne
+ depends = r-s4vectors
+ depends = r-scater
+ depends = r-scran
+ depends = r-shiny
+ depends = r-shinycssloaders
+ depends = r-shinydashboard
+ depends = r-shinydashboardplus
+ depends = r-shinyfiles
+ depends = r-shinyhelper
+ depends = r-shinyjs
+ depends = r-shinywidgets
+ depends = r-singlecellexperiment
+ depends = r-stringdist
+ depends = r-summarizedexperiment
+ depends = r-sushi
+ depends = r-tibble
+ depends = r-tidyr
+ depends = r-umap
+ depends = r-viridis
+ depends = r-gggenes
+ optdepends = r-biocstyle
+ optdepends = r-future
+ optdepends = r-knitr
+ optdepends = r-markdown
+ optdepends = r-rmarkdown
+ optdepends = r-signac
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/ChromSCape_1.6.0.tar.gz
+ sha256sums = 30abed31221e86e32a21a32f2e2c6428bf67eeb31965da468d8b56aa2f057343
+
+pkgname = r-chromscape
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df4af11e0499
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,83 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=ChromSCape
+_pkgver=1.6.0
+pkgname=r-${_pkgname,,}
+pkgver=1.6.0
+pkgrel=1
+pkgdesc='Analysis of single-cell epigenomics datasets with a Shiny App'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-batchelor
+ r-biocparallel
+ r-colorramps
+ r-colourpicker
+ r-consensusclusterplus
+ r-coop
+ r-delayedarray
+ r-dplyr
+ r-dt
+ r-edger
+ r-forcats
+ r-fs
+ r-genomicranges
+ r-ggplot2
+ r-iranges
+ r-irlba
+ r-jsonlite
+ r-kableextra
+ r-matrixtests
+ r-msigdbr
+ r-plotly
+ r-qs
+ r-qualv
+ r-rcpp
+ r-rlist
+ r-rsamtools
+ r-rtracklayer
+ r-rtsne
+ r-s4vectors
+ r-scater
+ r-scran
+ r-shiny
+ r-shinycssloaders
+ r-shinydashboard
+ r-shinydashboardplus
+ r-shinyfiles
+ r-shinyhelper
+ r-shinyjs
+ r-shinywidgets
+ r-singlecellexperiment
+ r-stringdist
+ r-summarizedexperiment
+ r-sushi
+ r-tibble
+ r-tidyr
+ r-umap
+ r-viridis
+ r-gggenes
+)
+optdepends=(
+ r-biocstyle
+ r-future
+ r-knitr
+ r-markdown
+ r-rmarkdown
+ r-signac
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('30abed31221e86e32a21a32f2e2c6428bf67eeb31965da468d8b56aa2f057343')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: