summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 06:27:06 +0800
committerSukanka2022-06-06 06:27:06 +0800
commitee6594bdb332da412286360f431986aaf0c3d437 (patch)
tree0002bc5f66e954704f330196d717b815cc1ce404
downloadaur-ee6594bdb332da412286360f431986aaf0c3d437.tar.gz
add r-clippda
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f0aea0edf04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = r-clippda
+ pkgdesc = A package for the clinical proteomic profiling data analysis
+ pkgver = 1.46.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/clippda
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-biobase
+ depends = r-limma
+ depends = r-rgl
+ depends = r-scatterplot3d
+ depends = r-statmod
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/clippda_1.46.0.tar.gz
+ sha256sums = a78dedc7b032321d38403d4780e2eb2b7badc2c724b655c032c275c86c7013da
+
+pkgname = r-clippda
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91911b8246a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=clippda
+_pkgver=1.46.0
+pkgname=r-${_pkgname,,}
+pkgver=1.46.0
+pkgrel=1
+pkgdesc='A package for the clinical proteomic profiling data analysis'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-biobase
+ r-limma
+ r-rgl
+ r-scatterplot3d
+ r-statmod
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('a78dedc7b032321d38403d4780e2eb2b7badc2c724b655c032c275c86c7013da')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: