summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 06:38:30 +0800
committerSukanka2022-06-06 06:38:30 +0800
commitfd7a360b6ca95a22d8181e1c4e1cf5dcde00f128 (patch)
treee4747638c16409a99ed67e578abc92fb57032006
downloadaur-fd7a360b6ca95a22d8181e1c4e1cf5dcde00f128.tar.gz
add r-cmap
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03d20c05ebdf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = r-cmap
+ pkgdesc = A data package containing annotation data for cMAP
+ pkgver = 1.15.1
+ pkgrel = 5
+ url = https://bioconductor.org/packages/cMAP
+ arch = any
+ license = LGPL
+ depends = r
+ source = https://bioconductor.org/packages/release/data/annotation/src/contrib/cMAP_1.15.1.tar.gz
+ sha256sums = 3bf24aca1ce63ebff4ac0172467ecd8acbb0c1f8a240cd0f8b8abd7c44fdf15f
+
+pkgname = r-cmap
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed2652e9dd8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=cMAP
+_pkgver=1.15.1
+pkgname=r-${_pkgname,,}
+pkgver=1.15.1
+pkgrel=5
+pkgdesc='A data package containing annotation data for cMAP'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('LGPL')
+depends=(
+ r
+)
+source=("https://bioconductor.org/packages/release/data/annotation/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('3bf24aca1ce63ebff4ac0172467ecd8acbb0c1f8a240cd0f8b8abd7c44fdf15f')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: