summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 06:44:21 +0800
committerSukanka2022-06-06 06:44:21 +0800
commitac6b18389d2f704c40e945c8a8e45fecbd6e5dc6 (patch)
treeb37fe426bba864658a87457632f4e96f8f2b5f46
downloadaur-ac6b18389d2f704c40e945c8a8e45fecbd6e5dc6.tar.gz
add r-cnvgears
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD44
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3804bc0bd592
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = r-cnvgears
+ pkgdesc = A Framework of Functions to Combine, Analize and Interpret CNVs Calling Results
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/CNVgears
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-data.table
+ depends = r-ggplot2
+ optdepends = r-biomart
+ optdepends = r-cn.mops
+ optdepends = r-cowplot
+ optdepends = r-delayedarray
+ optdepends = r-devtools
+ optdepends = r-evobir
+ optdepends = r-genomicranges
+ optdepends = r-knitr
+ optdepends = r-r.utils
+ optdepends = r-rmarkdown
+ optdepends = r-scales
+ optdepends = r-testthat
+ optdepends = r-usethis
+ optdepends = r-variantannotation
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/CNVgears_1.4.0.tar.gz
+ sha256sums = ca3bd38f874ca4dccdd89243e44085159a533e08ebad9505183299a5fbda23d9
+
+pkgname = r-cnvgears
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbd59b7a6179
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=CNVgears
+_pkgver=1.4.0
+pkgname=r-${_pkgname,,}
+pkgver=1.4.0
+pkgrel=1
+pkgdesc='A Framework of Functions to Combine, Analize and Interpret CNVs Calling Results'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-data.table
+ r-ggplot2
+)
+optdepends=(
+ r-biomart
+ r-cn.mops
+ r-cowplot
+ r-delayedarray
+ r-devtools
+ r-evobir
+ r-genomicranges
+ r-knitr
+ r-r.utils
+ r-rmarkdown
+ r-scales
+ r-testthat
+ r-usethis
+ r-variantannotation
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('ca3bd38f874ca4dccdd89243e44085159a533e08ebad9505183299a5fbda23d9')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: