summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 06:47:02 +0800
committerSukanka2022-06-06 06:47:02 +0800
commited18d379d01728eea341db2e56d714e1ad50e809 (patch)
tree6118fd1d6713c63e8728aada6e8345f887bf9675
downloadaur-ed18d379d01728eea341db2e56d714e1ad50e809.tar.gz
add r-cocitestats
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a1d6f9cc109
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-cocitestats
+ pkgdesc = Different test statistics based on co-citation.
+ pkgver = 1.68.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/CoCiteStats
+ arch = any
+ license = CPL
+ depends = r
+ depends = r-annotationdbi
+ depends = r-org.hs.eg.db
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/CoCiteStats_1.68.0.tar.gz
+ sha256sums = be90d733faedf289bb3df3f85367559006914375b336e9993fdff5f7fbeceaa9
+
+pkgname = r-cocitestats
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..264dbe3ff734
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=CoCiteStats
+_pkgver=1.68.0
+pkgname=r-${_pkgname,,}
+pkgver=1.68.0
+pkgrel=1
+pkgdesc='Different test statistics based on co-citation.'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('CPL')
+depends=(
+ r
+ r-annotationdbi
+ r-org.hs.eg.db
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('be90d733faedf289bb3df3f85367559006914375b336e9993fdff5f7fbeceaa9')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: