summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 06:47:49 +0800
committerSukanka2022-06-06 06:47:49 +0800
commit9a54bab254250ee1a5b0fd43591b621eeeda1967 (patch)
tree4aed2d457f469a72a58dd0b598530c76dd7a5366
downloadaur-9a54bab254250ee1a5b0fd43591b621eeeda1967.tar.gz
add r-cocor
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ef98741a38a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-cocor
+ pkgdesc = Comparing Correlations
+ pkgver = 1.1.3
+ pkgrel = 7
+ url = https://cran.r-project.org/package=cocor
+ arch = any
+ license = GPL
+ depends = r
+ optdepends = r-rkward
+ optdepends = r-testthat
+ source = https://cran.r-project.org/src/contrib/cocor_1.1-3.tar.gz
+ sha256sums = 22503ef02f450e2c60056d286603faa3ac0789fc45ed0b9e9788c6eb73f6df80
+
+pkgname = r-cocor
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2cc74fe0dbf9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: sukanka <su975853527@gmail.com>
+
+_pkgname=cocor
+_pkgver=1.1-3
+pkgname=r-${_pkgname,,}
+pkgver=1.1.3
+pkgrel=7
+pkgdesc='Comparing Correlations'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+)
+optdepends=(
+ r-rkward
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('22503ef02f450e2c60056d286603faa3ac0789fc45ed0b9e9788c6eb73f6df80')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: