summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-07-15 12:02:10 +0000
committerBioArchLinuxBot2023-07-15 12:02:10 +0000
commit3802308e9016f9bcf419739f2011bc98bb234024 (patch)
treee1501428dcfa3e0a6573d19115fb8bcdd7ebc75f
parenta3fda3b8cde1df69dbd2d065920a0ad2749ab410 (diff)
downloadaur-3802308e9016f9bcf419739f2011bc98bb234024.tar.gz
[lilac] updated to 0.19.4-12
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD23
2 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5967f939aacb..0bcffc6ce98f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = r-coda
pkgdesc = Output Analysis and Diagnostics for MCMC
pkgver = 0.19.4
- pkgrel = 10
+ pkgrel = 12
url = https://cran.r-project.org/package=coda
arch = any
license = GPL
depends = r
source = https://cran.r-project.org/src/contrib/coda_0.19-4.tar.gz
+ md5sums = 23122681735275c7178481d819440039
sha256sums = 422d3cfd34797a3631e9c4812431940599c0ca4bb9937797bed07b7b1d6fe58f
pkgname = r-coda
diff --git a/PKGBUILD b/PKGBUILD
index 45d308b2da56..e3c82d554912 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,32 @@
-# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Ward Segers <w@rdsegers.be>
# Contributor: Alex Branham <alex.branham@gmail.com>
+# Contributor: fordprefect <fordprefect@dukun.de>
_pkgname=coda
_pkgver=0.19-4
pkgname=r-${_pkgname,,}
-pkgver=0.19.4
-pkgrel=10
-pkgdesc='Output Analysis and Diagnostics for MCMC'
-arch=('any')
+pkgver=${_pkgver//-/.}
+pkgrel=12
+pkgdesc="Output Analysis and Diagnostics for MCMC"
+arch=(any)
url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+license=(GPL)
depends=(
r
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('23122681735275c7178481d819440039')
sha256sums=('422d3cfd34797a3631e9c4812431940599c0ca4bb9937797bed07b7b1d6fe58f')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: