summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-03-10 03:21:04 +0300
committerViktor Drobot2020-03-10 03:21:04 +0300
commit8b512860de8a090bf8a5208cb3f3fb131909d1e4 (patch)
tree8e33e4e9711aaea5cf4d14975e88570e58885905
parentb906728e13133d27df041a747af0cbefef8442d8 (diff)
downloadaur-8b512860de8a090bf8a5208cb3f3fb131909d1e4.tar.gz
Fixed PKGBUILD
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD36
2 files changed, 27 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4cb6c22b8c02..a30aa67dc10a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = r-coda
pkgdesc = Output Analysis and Diagnostics for MCMC
- pkgver = 0.19.2
+ pkgver = 0.19.3
pkgrel = 1
url = https://cran.r-project.org/package=coda
arch = any
- license = GPL
- depends = r
- replaces = r-cran-coda
- source = https://cran.r-project.org/src/contrib/coda_0.19-2.tar.gz
- md5sums = 0c5d6b732fe5bcb7a8e52ae3ae6a311f
+ license = GPL2
+ license = GPL3
+ depends = r>=2.14.0
+ source = https://cran.r-project.org/src/contrib/coda_0.19-3.tar.gz
+ md5sums = 2e32c8217920c2824229217a95fb8228
pkgname = r-coda
diff --git a/PKGBUILD b/PKGBUILD
index 5e0394aba958..86fd1b2fa049 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,29 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Ward Segers <w@rdsegers.be>
# Contributor: Alex Branham <alex.branham@gmail.com>
-_cranver=0.19-2
-pkgname=r-coda
+
+_cranname=coda
+_cranver=0.19-3
+pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc='Output Analysis and Diagnostics for MCMC'
-arch=('any')
-url='https://cran.r-project.org/package=coda'
-license=('GPL')
-depends=('r' )
-replaces=('r-cran-coda')
-source=("https://cran.r-project.org/src/contrib/coda_"$_cranver".tar.gz")
-md5sums=('0c5d6b732fe5bcb7a8e52ae3ae6a311f')
+pkgdesc="Output Analysis and Diagnostics for MCMC"
+arch=(any)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(GPL2 GPL3)
+depends=('r>=2.14.0')
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('2e32c8217920c2824229217a95fb8228')
+
+build() {
+ cd "${srcdir}"
-build(){
- R CMD INSTALL coda_"$_cranver".tar.gz -l "$srcdir"
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
}
+
package() {
- install -dm0755 "$pkgdir"/usr/lib/R/library
- cp -a --no-preserve=ownership coda "$pkgdir"/usr/lib/R/library
-}
+ cd "${srcdir}"
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+}