summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsukanka2022-07-21 22:46:02 +0800
committersukanka2022-07-21 22:46:02 +0800
commitef1575dca69426ad99286cf8feb5b703accefa4a (patch)
tree9e19143286bfe6ec15769967a9a84be3007cb8ec
parent05432b90f313991f571e912374d8bab79965c457 (diff)
downloadaur-ef1575dca69426ad99286cf8feb5b703accefa4a.tar.gz
takeover package
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD34
2 files changed, 20 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f72df558ba49..519f5dabb847 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = r-coda
pkgdesc = Output Analysis and Diagnostics for MCMC
pkgver = 0.19.4
- pkgrel = 1
+ pkgrel = 4
url = https://cran.r-project.org/package=coda
arch = any
- license = GPL2
- license = GPL3
- depends = r>=2.14.0
+ license = GPL
+ depends = r
source = https://cran.r-project.org/src/contrib/coda_0.19-4.tar.gz
sha256sums = 422d3cfd34797a3631e9c4812431940599c0ca4bb9937797bed07b7b1d6fe58f
diff --git a/PKGBUILD b/PKGBUILD
index be7deeb25993..7f6b6f96af16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
-# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
-# Contributor: Ward Segers <w@rdsegers.be>
-# Contributor: Alex Branham <alex.branham@gmail.com>
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
-_cranname=coda
-_cranver=0.19-4
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=1
-pkgdesc="Output Analysis and Diagnostics for MCMC"
-arch=(any)
-url="https://cran.r-project.org/package=${_cranname}"
-license=(GPL2 GPL3)
-depends=('r>=2.14.0')
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+_pkgname=coda
+_pkgver=0.19-4
+pkgname=r-${_pkgname,,}
+pkgver=0.19.4
+pkgrel=4
+pkgdesc='Output Analysis and Diagnostics for MCMC'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
sha256sums=('422d3cfd34797a3631e9c4812431940599c0ca4bb9937797bed07b7b1d6fe58f')
build() {
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
}
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
-
- cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
}
+# vim:set ts=2 sw=2 et: