summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-12-08 18:43:34 +0200
committerPekka Ristola2023-12-08 18:43:34 +0200
commitd3c541998ddbe158decc7a5d23622ed67c238f02 (patch)
treeb04af95b4ff8a35bc34232ef90cde75b4b06da12
downloadaur-d3c541998ddbe158decc7a5d23622ed67c238f02.tar.gz
Version 1.6.0
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD52
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81cc6356692e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = r-comethdmr
+ pkgdesc = Accurate identification of co-methylated and differentially methylated regions in epigenome-wide association studies
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/coMethDMR
+ arch = any
+ license = GPL3
+ checkdepends = r-illuminahumanmethylation450kanno.ilmn12.hg19
+ checkdepends = r-sesamedata
+ checkdepends = r-testthat
+ depends = r-annotationhub
+ depends = r-biocparallel
+ depends = r-bumphunter
+ depends = r-experimenthub
+ depends = r-genomicranges
+ depends = r-iranges
+ depends = r-lmertest
+ optdepends = r-biocstyle
+ optdepends = r-corrplot
+ optdepends = r-illuminahumanmethylation450kanno.ilmn12.hg19
+ optdepends = r-illuminahumanmethylationepicanno.ilm10b4.hg19
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/coMethDMR_1.6.0.tar.gz
+ md5sums = 0a6229d90868a4a60eb0f72c4499d1fc
+ sha256sums = a5d26df311e9e10344634d51e8382c5cc2a6cc11a645087fed6ffb880287bade
+
+pkgname = r-comethdmr
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5589e474746b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=coMethDMR
+_pkgver=1.6.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Accurate identification of co-methylated and differentially methylated regions in epigenome-wide association studies"
+arch=(any)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(GPL3)
+depends=(
+ r-annotationhub
+ r-biocparallel
+ r-bumphunter
+ r-experimenthub
+ r-genomicranges
+ r-iranges
+ r-lmertest
+)
+checkdepends=(
+ r-illuminahumanmethylation450kanno.ilmn12.hg19
+ r-sesamedata
+ r-testthat
+)
+optdepends=(
+ r-biocstyle
+ r-corrplot
+ r-illuminahumanmethylation450kanno.ilmn12.hg19
+ r-illuminahumanmethylationepicanno.ilm10b4.hg19
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('0a6229d90868a4a60eb0f72c4499d1fc')
+sha256sums=('a5d26df311e9e10344634d51e8382c5cc2a6cc11a645087fed6ffb880287bade')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}