summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Branham2018-05-31 17:05:01 -0500
committerAlex Branham2018-05-31 17:05:01 -0500
commit07abaea00d6483dd220bfec6aef4380bc3950f88 (patch)
tree9969638282649ab5c7264251b5078d8dc646e634
downloadaur-07abaea00d6483dd220bfec6aef4380bc3950f88.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58470e4c7376
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-commonmark
+ pkgdesc = High Performance CommonMark and Github Markdown Rendering in R
+ pkgver = 1.5
+ pkgrel = 1
+ url = https://cran.r-project.org/package=commonmark
+ arch = x86_64
+ license = BSD_2_clause + file LICENSE
+ depends = r
+ optdepends = r-curl
+ source = https://cran.r-project.org/src/contrib/commonmark_1.5.tar.gz
+ md5sums = 61cd4dabb77e59c7994fd73407936013
+
+pkgname = r-commonmark
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da28dd8b6c8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alex Branham <branham@utexas.edu>
+_cranname=commonmark
+_cranver=1.5
+_pkgtar=${_cranname}_${_cranver}.tar.gz
+pkgname=r-commonmark
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="High Performance CommonMark and Github Markdown Rendering in R"
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_cranname}"
+license=('BSD_2_clause + file LICENSE')
+depends=('r' )
+
+optdepends=('r-curl')
+
+source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+md5sums=('61cd4dabb77e59c7994fd73407936013')
+
+build(){
+ R CMD INSTALL ${_pkgtar} -l $srcdir
+}
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+}
+