summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 07:11:33 +0800
committerSukanka2022-06-06 07:11:33 +0800
commit2e2acd4d3e140dc72c5ea07b6e6418275647185e (patch)
treef87b3a6f287a1e1cea072b1a8575daa4d08a1ea0
downloadaur-2e2acd4d3e140dc72c5ea07b6e6418275647185e.tar.gz
add r-corncob
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD45
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8a1fc7cfba2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = r-corncob
+ pkgdesc = Count Regression for Correlated Observations with the Beta-Binomial
+ pkgver = 0.2.0
+ pkgrel = 3
+ url = https://cran.r-project.org/package=corncob
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-detectseparation
+ depends = r-dplyr
+ depends = r-ggplot2
+ depends = r-magrittr
+ depends = r-numderiv
+ depends = r-optimr
+ depends = r-phyloseq
+ depends = r-rmutil
+ depends = r-scales
+ depends = r-trust
+ depends = r-vgam
+ optdepends = r-covr
+ optdepends = r-knitr
+ optdepends = r-limma
+ optdepends = r-r.rsp
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://cran.r-project.org/src/contrib/corncob_0.2.0.tar.gz
+ sha256sums = c3731016c9d05d5bcd4c830db3da6a75dcde85a5d36ed6fbc4897fc7a1fd15e1
+
+pkgname = r-corncob
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13c1b398af80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=corncob
+_pkgver=0.2.0
+pkgname=r-${_pkgname,,}
+pkgver=0.2.0
+pkgrel=3
+pkgdesc='Count Regression for Correlated Observations with the Beta-Binomial'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-detectseparation
+ r-dplyr
+ r-ggplot2
+ r-magrittr
+ r-numderiv
+ r-optimr
+ r-phyloseq
+ r-rmutil
+ r-scales
+ r-trust
+ r-vgam
+)
+optdepends=(
+ r-covr
+ r-knitr
+ r-limma
+ r-r.rsp
+ r-rmarkdown
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('c3731016c9d05d5bcd4c830db3da6a75dcde85a5d36ed6fbc4897fc7a1fd15e1')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: