summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-12-17 18:06:21 +0000
committerBioArchLinuxBot2023-12-17 18:06:21 +0000
commitf63e29a3f61e2bb2230ac54304464065e76e9f96 (patch)
tree6f65911ddbc4d9f7896c039603d6f72caeb9fb47
parent024ccff73392308e0356dd7e417d93a2e97a0fdb (diff)
downloadaur-r-corrplot.tar.gz
[lilac] updated to 0.92-12
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD27
2 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e9d4337f6b1..8b51576fe9fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = r-corrplot
pkgdesc = Visualization of a Correlation Matrix
pkgver = 0.92
- pkgrel = 10
+ pkgrel = 12
url = https://cran.r-project.org/package=corrplot
arch = any
license = MIT
@@ -14,6 +14,7 @@ pkgbase = r-corrplot
optdepends = r-seriation
optdepends = r-testthat
source = https://cran.r-project.org/src/contrib/corrplot_0.92.tar.gz
- sha256sums = e8c09f963f9c4837036c439ebfe00fa3a6e462ccbb786d2cf90850ddcd9428bd
+ md5sums = 487452ee9efd5cfbf710e379321f42f8
+ b2sums = d3b55562f7844e565400166847ceecf05cb4a5e23a4ff4c0994164bca494e5e1deb7f99327a6e0ef91d999df73fd7dce7948a27aa7ecbb77f480a19d6039131f
pkgname = r-corrplot
diff --git a/PKGBUILD b/PKGBUILD
index 6398d9d35aa2..71b9f0bbdaa6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
_pkgname=corrplot
_pkgver=0.92
pkgname=r-${_pkgname,,}
-pkgver=0.92
-pkgrel=10
-pkgdesc='Visualization of a Correlation Matrix'
-arch=('any')
-url="https://cran.r-project.org/package=${_pkgname}"
-license=('MIT')
+pkgver=${_pkgver//-/.}
+pkgrel=12
+pkgdesc="Visualization of a Correlation Matrix"
+arch=(any)
+url="https://cran.r-project.org/package=$_pkgname"
+license=(MIT)
depends=(
r
)
@@ -23,15 +23,18 @@ optdepends=(
r-testthat
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('e8c09f963f9c4837036c439ebfe00fa3a6e462ccbb786d2cf90850ddcd9428bd')
+md5sums=('487452ee9efd5cfbf710e379321f42f8')
+b2sums=('d3b55562f7844e565400166847ceecf05cb4a5e23a4ff4c0994164bca494e5e1deb7f99327a6e0ef91d999df73fd7dce7948a27aa7ecbb77f480a19d6039131f')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
- install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
}
-# vim:set ts=2 sw=2 et: